php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #36082 Uppercase extension name
Submitted: 2006-01-19 12:40 UTC Modified: 2006-01-19 13:02 UTC
From: agony at drinkki dot com Assigned:
Status: Not a bug Package: Dynamic loading
PHP Version: 4.4.2 OS: Windows XP
Private report: No CVE-ID: None
 [2006-01-19 12:40 UTC] agony at drinkki dot com
Description:
------------
Extensions cannot have uppercase characters in their names. extension_loaded return true, get_extension_functions return declared functions but using functions return undeclared function error and function_exists return false.

If extension name is only lowercase, everything will work fine (eg. "myOwnExtension" named as "myownextension" or "my_own_extension").

Reproduce code:
---------------
<?php
$ext = "myOwnExtension";
echo "{$ext} test\n\n";
echo "{$ext} is loaded: " . var_export(extension_loaded($ext), TRUE) . "\n\n";
echo "Extension functions:\n\n";
$funcs = get_extension_funcs($ext);
foreach ($funcs as $f) {
   echo "{$f} " . var_export(function_exists($f), TRUE) . "\n";
}

Expected result:
----------------
MyOwnExtension test

MyOwnExtension is loaded: true

Extension functions:

MyOwnFunction true

Actual result:
--------------
MyOwnExtension test

MyOwnExtension is loaded: true

Extension functions:

MyOwnFunction false

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2006-01-19 13:02 UTC] tony2001@php.net
Sorry, but your problem does not imply a bug in PHP itself.  For a
list of more appropriate places to ask for help using PHP, please
visit http://www.php.net/support.php as this bug system is not the
appropriate forum for asking support questions.  Due to the volume
of reports we can not explain in detail here why your report is not
a bug.  The support channels will be able to provide an explanation
for you.

Thank you for your interest in PHP.


 
PHP Copyright © 2001-2024 The PHP Group
All rights reserved.
Last updated: Mon Feb 26 15:01:29 2024 UTC