php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #36078 chdir on ClearCase drive
Submitted: 2006-01-19 09:05 UTC Modified: 2006-01-20 10:47 UTC
From: jarek at katnik dot pl Assigned:
Status: Not a bug Package: Directory function related
PHP Version: 5.1.2 OS: Windows XP Pro SP2
Private report: No CVE-ID: None
 [2006-01-19 09:05 UTC] jarek at katnik dot pl
Description:
------------
When I run chdir on drive mounted by ClearCase
I get warrning and directory doesn't change.

Reproduce code:
---------------
<?php
    //Drive 'R:' is mounted by ClearCase.
    chdir('R:');
?>


Expected result:
----------------
workinf directory should change to r:

Actual result:
--------------
Warning: chdir() [function.chdir]: No such file or directory (errno 2)
in {scriptName} on line {lineNumber}

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2006-01-19 09:08 UTC] sniper@php.net
Blame Microsoft..or IBM. Not PHP bug.
 [2006-01-20 10:10 UTC] jarek at katnik dot pl
What makes you think that it is Microsoft or IBM bug?
By the way as far as I know ClearCase is developed by Rational Rose not by IBM.

I found something intresting which could make some clue.
This problem occurs only if I run the script through web server (Apache/1.3.31). From command line the script works fine.

The script:
<?php     
    print 'Testing hard drive: ' . (chdir('d:')?'ok':'error');
    print "\r\n";
    print 'Testing ClearCase drive: ' . (chdir('r:')?'ok':'error');
?>

Apache output:
Testing hard drive: ok
Warning: chdir() [function.chdir]: No such file or directory (errno 2) in e:\www\regrCmd\test.php on line 4
Testing ClearCase drive: error

Command line output:
E:\www\regrCmd>php test.php
Testing hard drive: ok
Testing ClearCase drive: ok

With best regards
  JK
 [2006-01-20 10:47 UTC] tony2001@php.net
Duplicate of bug #35691.
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Fri Dec 04 18:01:23 2020 UTC