php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #36055 [Tue Jan 17 10:28:18 2006] [notice] Parent: child process exited with status 32
Submitted: 2006-01-17 17:02 UTC Modified: 2006-01-18 00:44 UTC
From: paul at simonway dot com Assigned:
Status: Closed Package: OCI8 related
PHP Version: 5.1.2 OS: windows xp
Private report: No CVE-ID:
 [2006-01-17 17:02 UTC] paul at simonway dot com
Description:
------------
OCI calls work with php5.1.1/Apache2.0.50(c:/php/php5apache2.dll)/Windows XP. 

OCI calls do NOT work after updating from php5.1.1 to php5.1.2.

The php script that works with 5.1.1 crashes when using 5.1.2:

    [Tue Jan 17 10:50:32 2006] [notice] Parent: child process exited with status 3221225477 -- Restarting.

Reproduce code:
---------------
$conn = @ocilogon('****','****','9i');

if($error = ocierror())
    print(var_export($error,true));
                     
$stmt = ociparse($conn, 'SELECT SYSDATE FROM DUAL');

if(!$stmt) 
    print var_export(ocierror($stmt),true);

   
if(!@ociexecute($stmt)) 
{
        $error = ocierror($stmt);
        print var_export($error,true);
}

ocifetchinto($stmt, $row, OCI_ASSOC | OCI_RETURN_NULLS | OCI_RETURN_LOBS);
print_r($row);

Expected result:
----------------
Array ( [SYSDATE] => 17-JAN-06 ) 

Actual result:
--------------
Apache system crash:

[Tue Jan 17 10:50:32 2006] [notice] Parent: child process exited with status 3221225477 -- Restarting.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2006-01-17 17:16 UTC] tony2001@php.net
Thank you for this bug report. To properly diagnose the problem, we
need a backtrace to see what is happening behind the scenes. To
find out how to generate a backtrace, please read
http://bugs.php.net/bugs-generating-backtrace.php for *NIX and
http://bugs.php.net/bugs-generating-backtrace-win32.php for Win32

Once you have generated a backtrace, please submit it to this bug
report and change the status back to "Open". Thank you for helping
us make PHP better.

Can't reproduce.
Remove all the @ and make sure you have set all the required environment variables.
 [2006-01-17 21:28 UTC] paul at simonway dot com
I ran the script (oci.php) from the command line. PHP 5.1.1 worked as expected, no problem. 

PHP 5.1.2 printed out the expected result but crashed before returning to the command line prompt:

C:\php\scripts>php oci.php
Array
(
    [SYSDATE] => 17-JAN-06
)



I downloaded the *.pdb from snaps and put them in the c:/php and c:/php/ext directories. However, when the script crashes and I choose debug, Microsoft Visual C++ .NET debugger reports "No symbols loaded" for all files loaded by php.exe. 

Here's the last bit of info from the debugger 'output' window:

[snip]
'php.exe': Loaded 'C:\WINDOWS\SYSTEM32\apphelp.dll', No symbols loaded.
The thread 'Win32 Thread' (0xb60) has exited with code 0 (0x0).
Unhandled exception at 0x6066dfbe in php.exe: 0xC0000005: Access violation reading location 0x00f8d270.
'C:\php\ext\php_oci8.dll', No symbols loaded.
[/snip]


I don't know how to load the symbols. Perhaps, somebody will have the same problem and shed light on this. Thanks.
 [2006-01-17 21:39 UTC] tony2001@php.net
Please reopen when you have any additional info about it.
Until then -> bogus.
 [2006-01-17 23:56 UTC] edink@php.net
I can reproduce it with the fallowing call stack:

ORAOCIICUS10! 00c3312f()
ORAOCIICUS10! 00c330f4()
ORAOCIICUS10! 01049034()
OCI! 00bd706c()
php_oci_statement_free(php_oci_statement * 0x00bb18a1, void * * * 0x00a80d08) line 588 + 8 bytes
php_oci_statement_list_dtor(_zend_rsrc_list_entry * 0x00a80d98, void * * * 0x00324138) line 701 + 17 bytes
list_entry_destructor(void * 0x00a80d98) line 184 + 4 bytes
zend_hash_del_key_or_index(_hashtable * 0x100a7c82, char * 0x00328f78, unsigned int 0, unsigned long 0, int 5) line 490 + 6 bytes
_zend_list_delete(int 11013528, void * * * 0x00324138) line 58 + 30 bytes
_zval_dtor_func(_zval_struct * 0x00a80270) line 60 + 9 bytes
_zval_ptr_dtor(_zval_struct * * 0x00a80dcc) line 387 + 12 bytes
zend_hash_apply_deleter(_hashtable * 0x1009ad73, bucket * 0x00328ea8) line 574 + 6 bytes
zend_hash_graceful_reverse_destroy(_hashtable * 0x00328ea8) line 641
shutdown_executor(void * * * 0x00324138) line 217 + 23 bytes
zend_deactivate(void * * * 0x00324138) line 848
php_request_shutdown(void * 0x00000000) line 1287
main(int 4, char * * 0x003240e0) line 1231
PHP! mainCRTStartup + 227 bytes
KERNEL32! 7c816d4f()

 [2006-01-18 00:44 UTC] tony2001@php.net
This bug has been fixed in CVS.

Snapshots of the sources are packaged every three hours; this change
will be in the next snapshot. You can grab the snapshot at
http://snaps.php.net/.
 
Thank you for the report, and for helping us make PHP better.


 
PHP Copyright © 2001-2014 The PHP Group
All rights reserved.
Last updated: Mon Apr 21 04:01:57 2014 UTC