php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #3597 -g and -fast incompatible for auto-inlining
Submitted: 2000-02-23 18:43 UTC Modified: 2000-08-02 12:08 UTC
From: gerdts at cae dot wisc dot edu Assigned:
Status: Closed Package: Compile Warning
PHP Version: 4.0 Beta 4 Patch Level 1 OS: Solaris 2.6, 7, Sun's cc
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: gerdts at cae dot wisc dot edu
New email:
PHP Version: OS:

 

 [2000-02-23 18:43 UTC] gerdts at cae dot wisc dot edu
This assumes that the patch given in bug 3569 has been applied.

env CC=cc CFLAGS=-fast ./configure && make
...
Making all in Zend
/bin/sh ../libtool --silent --mode=compile cc -DHAVE_CONFIG_H -I. -I. -I..   -I/afs/engr.wisc.edu/src/gnu/include -I/afs/engr.wisc.edu/src/free/include -D_POSIX_PTHREAD_SEMANTICS -D_REENTRANT  -fast -g -c zend-scanner.c
cc: Warning: -g conflicts with auto-inlining, auto-inlining turned off

While this is not the correct fix, it does work...

*** Zend/Makefile.orig  Wed Feb 23 17:40:34 2000
--- Zend/Makefile       Wed Feb 23 17:40:42 2000
***************
*** 66,72 ****
  CXX = CC
  CXXCPP = 
  DLLTOOL = @DLLTOOL@
! INLINE_CFLAGS = -fast -g
  LD = /usr/ccs/bin/ld
  LEX = flex
  LIBTOOL = $(SHELL) $(top_builddir)/libtool --silent
--- 66,72 ----
  CXX = CC
  CXXCPP = 
  DLLTOOL = @DLLTOOL@
! INLINE_CFLAGS = -fast 
  LD = /usr/ccs/bin/ld
  LEX = flex
  LIBTOOL = $(SHELL) $(top_builddir)/libtool --silent

I don't have a good grasp on how the configure script is generated, else I would supply a patch that makes it so that fixes the cause of the problem, not the result of the problem.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2000-08-01 23:27 UTC] waldschrott@php.net
Please verify that it?s still happening using the latest version of PHP (release 4.0.1pl2 or CVS).
 [2000-08-02 12:08 UTC] hholzgra@php.net
well, -g is still default for CFLAGS even if
configure --disable-debug is given, and sun's
compiler won't have changed, so this is still 
in

but problems due to messing around with CFLAGS
shouldn't be considered a bug, so lets close it
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Thu Sep 29 16:05:53 2022 UTC