php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #35956 COM returning multidimensional variant array
Submitted: 2006-01-10 08:13 UTC Modified: 2006-01-10 12:01 UTC
Votes:1
Avg. Score:5.0 ± 0.0
Reproduced:0 of 0 (0.0%)
From: pilot_vijay at hotmail dot com Assigned: wez (profile)
Status: Not a bug Package: COM related
PHP Version: 5.0.5 OS: Windows XP
Private report: No CVE-ID: None
 [2006-01-10 08:13 UTC] pilot_vijay at hotmail dot com
Description:
------------
Hi,
  I call a COM function which returns a multi dimensional variant array of type VT_VARIANT|VT_ARRAY. I am using PHP 5.0.5 version.
   I have problems to print this multi array and I get a warning saying "can handle only 1 dimension variant arrays."
   Kindly find my code below and let me know where the problem is.

Reproduce code:
---------------
//call the COM
$instance = new COM("ArrayTry.myarray");

//define the VT_VARIANT|VT_ARRAY which will hold the multi dimensional variant array returned from the COM

$StringVariant = new VARIANT();

//call the COM function GetUserList() which returns the multi variant array 
$StringVariant=$instance->GetUserList();

print_r($StringVariant);  // here I get Object id #number as output in the php page



Expected result:
----------------
Should print the multi array and its associated elements.

Actual result:
--------------
display shows "Object ID#number"

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2006-01-10 12:01 UTC] sniper@php.net
Thank you for taking the time to report a problem with PHP.
Unfortunately you are not using a current version of PHP -- 
the problem might already be fixed. Please download a new
PHP version from http://www.php.net/downloads.php

If you are able to reproduce the bug with one of the latest
versions of PHP, please change the PHP version on this bug report
to the version you tested and change the status back to "Open".
Again, thank you for your continued support of PHP.


 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Sat Sep 21 13:01:27 2019 UTC