php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #35944 preg_match("/[^\\]/si",$string) or preg_match("/\\/si",$string) ecc don't works
Submitted: 2006-01-09 14:26 UTC Modified: 2006-01-09 14:55 UTC
Votes:1
Avg. Score:5.0 ± 0.0
Reproduced:1 of 1 (100.0%)
Same Version:1 (100.0%)
Same OS:1 (100.0%)
From: gidanmx2 at gmail dot com Assigned:
Status: Not a bug Package: *Regular Expressions
PHP Version: 5.1.1 OS: Windows XP
Private report: No CVE-ID: None
 [2006-01-09 14:26 UTC] gidanmx2 at gmail dot com
Description:
------------
The preg_match can't found [^\\].

Reproduce code:
---------------
$stringa = "\{test\}";
if(preg_match("/[^\\]/i",$stringa,$matches)){
echo "<p>Found";
} else {
echo "<p>Not found";
}

Expected result:
----------------
Found

Actual result:
--------------
Warning: preg_match() [function.preg-match]: Compilation failed: missing terminating ] for character class at offset 4 in C:\Documents and Settings\XPuser\Documenti\Eucalyptus\test.php on line 26

Not found

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2006-01-09 14:33 UTC] gidanmx2 at gmail dot com
Sorry, the Expected result is Not found not found, I have mistaken to write :P
 [2006-01-09 14:55 UTC] tony2001@php.net
Sorry, but your problem does not imply a bug in PHP itself.  For a
list of more appropriate places to ask for help using PHP, please
visit http://www.php.net/support.php as this bug system is not the
appropriate forum for asking support questions.  Due to the volume
of reports we can not explain in detail here why your report is not
a bug.  The support channels will be able to provide an explanation
for you.

Thank you for your interest in PHP.


 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Tue Jun 18 10:01:27 2019 UTC