php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Doc Bug #35912 [chm] bug on funcref.html
Submitted: 2006-01-05 23:42 UTC Modified: 2006-01-09 15:47 UTC
Votes:1
Avg. Score:1.0 ± 0.0
Reproduced:1 of 1 (100.0%)
Same Version:1 (100.0%)
Same OS:1 (100.0%)
From: jeff at adesigninteractive dot com Assigned: nlopess (profile)
Status: Not a bug Package: Documentation problem
PHP Version: Irrelevant OS: Yahoo! (AllTheWeb.com)
Private report: No CVE-ID: None
 [2006-01-05 23:42 UTC] jeff at adesigninteractive dot com
Description:
------------
I have found a bug on page funcref.html
[chm date: 2005-12-01]...

searched all the web context menu feature in CHM Manual

queried:
stripslashes + mail


Reproduce code:
---------------
not applicable



Expected result:
----------------
Submitted "All the Web" search from context menu in HTML ENHANCED CHM HELP FILES

Actual result:
--------------
http://www.alltheweb.com/search?cat=web&query=stripslashes+%2B+mail

The requested resource
/search
is no longer available on this server and there is no forwarding address. Please remove all references to this resource. 

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2006-01-06 10:24 UTC] vrana@php.net
It's problem of AllTheWeb. Try searching in the search box on their page, the result is same.
 [2006-01-06 13:35 UTC] nlopess@php.net
OK, but we can change the URL.
 [2006-01-06 17:11 UTC] vrana@php.net
I can't see how we can change the URL to fix this problem. When I enter "stripslashes + mail" in www.alltheweb.com I get the exactly same response. They use "q" instead of "query" parameter but the result is same.

With stronger escaping (stripslashes%20%2B%20mail instead of stripslashes+%2B+mail) it suddenly starts to work but as there is problem even in search from browser, the problem is definitely on their side.
 [2006-01-09 15:47 UTC] vrana@php.net
It will be better fixed directly on alltheweb.com.
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Tue Oct 27 02:01:24 2020 UTC