php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #35830 Type mismatch with bind variables
Submitted: 2005-12-28 20:31 UTC Modified: 2006-05-08 03:48 UTC
From: nate-php at seekio dot com Assigned: wez (profile)
Status: Closed Package: PDO related
PHP Version: 5CVS-2005-12-29 (snap) OS: Debian 3.1 Sarge
Private report: No CVE-ID: None
 [2005-12-28 20:31 UTC] nate-php at seekio dot com
Description:
------------
In PHP 5.1.1 bind variables no longer seem to work with the ODBC PDO driver connecting to DB2.  The same code that worked fine in 5.1.0 and previous now throws an exception in 5.1.1 and php5.1-200512222130 CVS snapshot:

The query I'm running is:
insert into nate.testdb values (?, ?)

The table is specified as:
create table tb.testdb (a int, b varchar(50))

Exception at line 13 of file testdb.php: SQLSTATE[22005]: Error in assignment: -99999 [IBM][CLI Driver] CLI0112E  Error in assignment. SQLSTATE=22005 (SQLExecute[-99999] at /usr/local/src/php-5.1.1/ext/pdo_odbc/odbc_stmt.c:133)

I looked up the db2 error code CLI0112E and this is what it said:

CLI0112E Error in assignment.  

Explanation: 

The data sent for a parameter or column was incompatible with the data type of the associated table column.  

User Response: 

Respecify the output binding through SQLBindCol or SQLGetData or the input binding through SQLSetParam or SQLBindParameter.

Reproduce code:
---------------
try {
  $db = new PDO('odbc:sample', 'webdb', 'xxx');
  $db->setAttribute(PDO::ATTR_ERRMODE, PDO::ERRMODE_EXCEPTION);
} catch (PDOException $e) {
  die("Connect failed: " . $e->getMessage() . "\n");
}

try {
  $query = "insert into nate.testdb values (?, ?)";
  $sth = $db->prepare($query);

  $sth->execute(array(1, 'foobar'))

} catch (Exception $e) {
  die("Exception at line " . $e->getLine() . " of file " . $e->getFile() . ": " . $e->getMessage() . "\n");
}


Expected result:
----------------
a row is inserted with the values of 1, and foobar in the a and b columns

Actual result:
--------------
Exception at line 13 of file testdb.php: SQLSTATE[22005]: Error in assignment: -99999 [IBM][CLI Driver] CLI0112E  Error in assignment. SQLSTATE=22005 (SQLExecute[-99999] at /usr/local/src/php-5.1.1/ext/pdo_odbc/odbc_stmt.c:133)

and no row is inserted.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2005-12-28 20:39 UTC] nate-php at seekio dot com
Oops, that create table statement should read:

create table nate.testdb (a int, b varchar(50))

(I had cut and pasted in the wrong schema)
 [2005-12-28 21:06 UTC] tony2001@php.net
>The same code that worked fine in 5.1.0
Are you sure?
The only difference between 5.1.0 and 5.1.1 is that 5.1.1 doesn't have Date class, which obviously doesn't affect PDO in any way.
 [2005-12-29 01:02 UTC] nate-php at seekio dot com
Yes, I'm quite sure.  I can install 5.1.0 and it works fine, touch nothing but the version and it stops working.  Here is the configure line for php, which I forgot to give earlier:

./configure  --with-apache=../apache_1.3.34 --with-mysql --with-pdo-mysql --with-gd --with-zlib --with-gettext --with-pdo-odbc=ibm-db2,/home/db2inst1/sqllib

The php.ini is just the php.ini-recommended from the tarball with no changes, and nothing in the apache conf overriding anything other than the include path.

Thanks,
Nate
 [2005-12-29 01:20 UTC] tony2001@php.net
Please try using this CVS snapshot:

  http://snaps.php.net/php5.1-latest.tar.gz
 
For Windows:
 
  http://snaps.php.net/win32/php5.1-win32-latest.zip


 [2005-12-29 01:32 UTC] nate-php at seekio dot com
Same thing:

Exception at line 19 of file testdb.php: SQLSTATE[22005]: Error in assignment: -99999 [IBM][CLI Driver] CLI0112E  Error in assignment. SQLSTATE=22005 (SQLExecute[-99999] at /usr/local/src/php5.1-200512282330/ext/pdo_odbc/odbc_stmt.c:133)
 [2005-12-29 10:08 UTC] sniper@php.net
Assigned to the PDO maintainer.
 [2006-04-09 07:41 UTC] wez@php.net
Please try using this CVS snapshot:

  http://snaps.php.net/php5.1-latest.tar.gz
 
For Windows:
 
  http://snaps.php.net/win32/php5.1-win32-latest.zip


 [2006-04-17 01:00 UTC] php-bugs at lists dot php dot net
No feedback was provided for this bug for over a week, so it is
being suspended automatically. If you are able to provide the
information that was originally requested, please do so and change
the status of the bug back to "Open".
 [2006-05-08 03:22 UTC] nate-php at seekio dot com
I just tested with php5.1-200605051830.tar.gz which shows up as PHP/5.1.5-dev in the server banner, and all seems to be working well.  I'll re-open the bug if we see this error again.

Thank you very much for getting this fixed!

Thanks,
Nate
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Thu Dec 02 00:03:42 2021 UTC