php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #35735 $EGREP and $SED are not defined in configure
Submitted: 2005-12-19 23:19 UTC Modified: 2005-12-19 23:29 UTC
From: selsky at columbia dot edu Assigned:
Status: Closed Package: Compile Failure
PHP Version: 4CVS-2005-12-19 (snap) OS: Solaris
Private report: No CVE-ID:
 [2005-12-19 23:19 UTC] selsky at columbia dot edu
Description:
------------
$EGREP is not defined in ./configure since the following is missing from ext/curl/config.m4:

  dnl properly set EGREP for AC_EGREP_CPP later on
  AC_CHECK_PROG(EGREP, egrep, grep -E)
  AC_SUBST(EGREP)


Reproduce code:
---------------
$ ./configure
--with-openssl=/opt/openssl-0.9.7i --with-curl=/opt/curl-7.11.1


Expected result:
----------------
[...]
checking for SSL support in libcurl... yes


Actual result:
--------------
[...]
checking for SSL support in libcurl... ../../src/configure: SSL: not found
no


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2005-12-19 23:29 UTC] sniper@php.net
This bug has been fixed in CVS.

Snapshots of the sources are packaged every three hours; this change
will be in the next snapshot. You can grab the snapshot at
http://snaps.php.net/.
 
Thank you for the report, and for helping us make PHP better.


 
PHP Copyright © 2001-2014 The PHP Group
All rights reserved.
Last updated: Mon Apr 21 10:02:10 2014 UTC