php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #35640 configure thinks in conjunction with java that sablot 1.0.1 is older than 0.96
Submitted: 2005-12-12 02:49 UTC Modified: 2005-12-12 18:28 UTC
Votes:1
Avg. Score:4.0 ± 0.0
Reproduced:1 of 1 (100.0%)
Same Version:0 (0.0%)
Same OS:0 (0.0%)
From: systemadministrator at internet dot lu Assigned:
Status: Wont fix Package: XSLT related
PHP Version: 4.4.1 OS: SuSE Linux 9.3
Private report: No CVE-ID: None
Have you experienced this issue?
Rate the importance of this bug to you:

 [2005-12-12 02:49 UTC] systemadministrator at internet dot lu
Description:
------------
always when i try to configure php with java, it exits saying:

checking for Sablotron libraries in the default path... found in /usr
checking for sablot-config... found
checking for Sablotron version... configure: error: Sablotron version 0.96 or greater required.

but i do have installed 1.0.1 on SuSE 9.3 :
newsrv:~/install/php-4.4.1 # /usr/bin/sablot-config --version
1.0.1
newsrv:~/install/php-4.4.1 #

Reproduce code:
---------------
./configure --enable-force-cgi-redirect --without-mm --enable-fastcgi --prefix=/var/fastcgi/php4.1.1 \
--with-openssl --with-zlib --enable-bcmath --with-bz2 --enable-calendar \
--with-curl --with-dom --with-dom-xslt --with-dom-exslt \
--enable-exif --enable-ftp --with-gd --with-jpeg-dir --with-png-dir \
--with-zlib-dir --with-freetype-dir --with-iconv \
--with-imap --with-imap-ssl --enable-mbstring --with-mcal=/usr \
--with-mcrypt --with-mhash --with-unixODBC=/usr --with-swf=/usr/lib/libswf \
--enable-wddx --enable-xml --enable-xslt --with-xslt-sablot --with-zip \
--with-pear --enable-memory-limit --enable-zend-multibyte \
--with-mysql --with-pgsql --with-java=/usr/java/jdk1.5.0_06

When i dont use java, there is no sablot error message:
./configure --enable-force-cgi-redirect --without-mm --enable-fastcgi --prefix=/var/fastcgi/php4.1.1 \
--with-openssl --with-zlib --enable-bcmath --with-bz2 --enable-calendar \
--with-curl --with-dom --with-dom-xslt --with-dom-exslt \
--enable-exif --enable-ftp --with-gd --with-jpeg-dir --with-png-dir \
--with-zlib-dir --with-freetype-dir --with-iconv \
--with-imap --with-imap-ssl --enable-mbstring --with-mcal=/usr \
--with-mcrypt --with-mhash --with-unixODBC=/usr --with-swf=/usr/lib/libswf \
--enable-wddx --enable-xml --enable-xslt --with-xslt-sablot --with-zip \
--with-pear --enable-memory-limit --enable-zend-multibyte \
--with-mysql --with-pgsql


Expected result:
----------------
the configure script should accept my version and NOT exit with a wrong error message

Actual result:
--------------
last lines from config.log:

configure:94187: checking for Sablotron version
configure:94212: gcc -o conftest -g -O2  -I/usr/include  -Wl,-rpath,/usr/ssl/lib -L/usr/ssl/lib -Wl,-rpath,/usr/java/jd
k1.5.0_06/jre/lib/i386/server -L/usr/java/jdk1.5.0_06/jre/lib/i386/server -Wl,-rpath,/usr/java/jdk1.5.0_06/jre/lib/i386
/native_threads -L/usr/java/jdk1.5.0_06/jre/lib/i386/native_threads -Wl,-rpath,/usr/java/jdk1.5.0_06/jre/lib/i386 -L/us
r/java/jdk1.5.0_06/jre/lib/i386 -Wl,-rpath,/usr/lib/libswf/lib -L/usr/lib/libswf/lib conftest.c -lswf -lcrypt -lpq -lmh
ash -lmcrypt -lltdl -ljava -lssl -lcrypto -lcrypt -lpam -lfreetype -lpng -lz -ljpeg -lexslt -lxml2 -lxslt -lz -lcurl -l
bz2 -lz -lssl -lcrypto -lresolv -lm -ldl -lnsl  -lcurl -lssl -lcrypto -ldl -lz -lxml2 -lz -lm -lodbc -lcrypt 1>&5
configure: failed program was:
#line 94194 "configure"
#include "confdefs.h"

#include <stdlib.h>
#include <sablot.h>

int main ()
{
        double version;
        version = atof(SAB_VERSION);

        if (version >= 0.96) {
                exit(0);
        }
        exit(255);
}


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2005-12-12 18:28 UTC] sniper@php.net
Neither of these are supported anymore. Install PHP 5.1 and start using ext/xsl and get the java-bridge thing from pecl instead.
 
PHP Copyright © 2001-2018 The PHP Group
All rights reserved.
Last updated: Thu Jun 21 14:01:42 2018 UTC