php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Request #35638 Adding udate to imap_fetch_overview results?
Submitted: 2005-12-11 23:18 UTC Modified: 2010-04-14 11:46 UTC
Votes:2
Avg. Score:5.0 ± 0.0
Reproduced:1 of 1 (100.0%)
Same Version:0 (0.0%)
Same OS:0 (0.0%)
From: charlesb at ekit-inc dot com Assigned: pajoye
Status: Closed Package: *General Issues
PHP Version: 4.4.1 OS: Solaris/i86
Private report: No CVE-ID:
 [2005-12-11 23:18 UTC] charlesb at ekit-inc dot com
Description:
------------
Would it be possible to add the arrival date for an email (preferably in unixtime) to the results for imap_fetch_overview?  It would help us _alot_ with our webmail.

Thanks, Charles



Patches

udate-in-imap-overview-r2 (last revision 2010-03-10 20:53 UTC) by Charles_Duffy at dell dot com)
udate-in-imap-overview (last revision 2010-03-09 20:14 UTC) by Charles_Duffy at dell dot com)

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2006-02-20 03:41 UTC] charlesb at ekit-inc dot com
Guys,

Any chance you could do this soon?

Last week I had to port a significant portion of our webmail system to python because PHP's imap functions weren't fast enough.  Having imap_fetch_overview return the arrival date would mean we could do away with a second call to the imap server, keep our inbox display nice and fast, and stay with PHP.

Thanks, Charles
 [2010-03-10 21:59 UTC] Charles_Duffy at Dell dot com
This issue is still unresolved on the PHP 5.3 and 5.4 branches; the attached patch is against the former, but rebases easily to 5.4 (with the possible exception of the test suite modifications; I will gladly do a rebase to current head myself to test if desired).

See also the mailing list thread beginning with http://news.php.net/php.internals/47097
 [2010-04-14 11:45 UTC] pajoye@php.net
Automatic comment from SVN on behalf of pajoye
Revision: http://svn.php.net/viewvc/?view=revision&revision=297983
Log: - #35638, add udate to imap_fetch_overview
 [2010-04-14 11:46 UTC] pajoye@php.net
-Status: Open +Status: Closed -Package: Feature/Change Request +Package: *General Issues -Assigned To: +Assigned To: pajoye
 [2010-04-14 11:46 UTC] pajoye@php.net
This bug has been fixed in SVN.

Snapshots of the sources are packaged every three hours; this change
will be in the next snapshot. You can grab the snapshot at
http://snaps.php.net/.
 
Thank you for the report, and for helping us make PHP better.


 
PHP Copyright © 2001-2014 The PHP Group
All rights reserved.
Last updated: Thu Apr 17 16:02:22 2014 UTC