php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #35633 gzdeflate function causes Apache Segmentation fault
Submitted: 2005-12-11 17:36 UTC Modified: 2006-01-25 00:24 UTC
From: krang at krang dot org dot uk Assigned:
Status: Not a bug Package: Zlib related
PHP Version: 4.4.1 OS: Red Hat 9
Private report: No CVE-ID: None
 [2005-12-11 17:36 UTC] krang at krang dot org dot uk
Description:
------------
Sorry, I don't know much about the gzdeflate() function, but it appears in one of the libraries I use (pclzip.lib.php) to create zip files.

When it gets executed, it always causes a "Segmentation fault" on Apache 1.3.34 (not sure about other versions)

I have re-compiled PHP 4.4.1, and done "make test" with no problems. This is my configure line:

./configure
    --prefix=/opt/php
    --with-apxs=/opt/apache/bin/apxs
    --with-config-file-path=/etc/
    --with-jpeg-dir=/usr/local/
    --with-zlib
    --with-gd
    --with-mysql=/opt/mysql/
    --with-openssl
    --with-kerberos


Reproduce code:
---------------
<?php

  gzdeflate('smeg');

?>



Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2005-12-11 18:44 UTC] sniper@php.net
Please try using this CVS snapshot:

  http://snaps.php.net/php5.1-latest.tar.gz
 
For Windows:
 
  http://snaps.php.net/win32/php5.1-win32-latest.zip


 [2005-12-11 19:47 UTC] krang at krang dot org dot uk
I'm really sorry, I cant upgrade PHP that simply... The problem is occurring on a production server with software which is not quite ready for PHP 5.
 [2005-12-11 20:02 UTC] judas dot iscariote at gmail dot com
use:

http://snaps.php.net/php4-STABLE-latest.tar.bz2
 [2005-12-11 20:05 UTC] iliaa@php.net
Cannot replicate in latest cvs.
 [2005-12-11 20:36 UTC] krang at krang dot org dot uk
Installed php4-STABLE-200512111736 (4.4.2RC2-dev), and I have  upgraded zlib to v1.2.3, but still doing a "Segmentation fault".
 [2006-01-25 00:24 UTC] krang at krang dot org dot uk
Just following up...

I've done an install of the final 4.4.2 version of PHP and all seems well, although earlier this week I have installed a fresh (custom) copy of zlib 1.2.3.

Originally this did not work, but this time I had read up on the need for the installer to create shared libraries. So the zlib installation used...

    ./configure
    make
    make install

    ./configure --shared
    make
    make install


Then it was then just a case of getting PHP to use this new installation, which by default uses /usr/local/...

./configure
    --prefix=/opt/php
    --with-apxs=/opt/apache/bin/apxs
    --with-config-file-path=/etc/
    --with-jpeg-dir=/usr/local/
    --with-zlib=/usr/local/
    --with-gd
    --with-mysql=/opt/mysql/
    --with-openssl
    --with-kerberos


I presume that the installation I have in /usr/ is corrupt or damaged in some way.

Anyway, sorry for wasting your time, and I hope this helps anyone else with the same problem.
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Wed Jan 29 08:01:25 2020 UTC