php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #356 Several install problems
Submitted: 1998-05-06 19:21 UTC Modified: 1998-05-21 13:35 UTC
From: jmorrow at alum dot mit dot edu Assigned: rasmus (profile)
Status: Closed Package: Installation problem
PHP Version: 3.0 Release Candidate 4 OS: Digital UNIX 4.0b
Private report: No CVE-ID: None
 [1998-05-06 19:21 UTC] jmorrow at alum dot mit dot edu
1) PHP is great!
2) PHP is quite difficult to install.

Here are several problems I had while installing on an
AlphaServer 400 running Digital UNIX 4.0b:

-"make clean" makes the distribution uncompilable!  After
doing this, make started using flex commands (it didn't the
first time).  However, my copy of flex allows neither the -o
or the -P flags, both of which are used.  If this is not an
oversight and I indeed have an outdated version of flex,
then configure should catch this.

-configure (the way I did it) puts the following lines into
the Makefile

LIBS = $(PHPLIBS)   regex/libregex.a -lgd -lm  -ldb \
         \
         \
         \
         \
       -L/usr/local/lib/mysql -lmysqlclient \
         \
         \
        \
         \
         \

With my copy of make, having a backslash on that last line
causes the compiler to try to find libraries called "all"
and "php" (the next two lines in the makefile).  It chokes.
Turning all the above stuff into one line fixed this problem.

-Not quite a bug but confusing: when setup asks for the
mysql install directory, it should have a smarter default.
The default install directory for mysql is "/usr/local".
This is technically correct, since it is the directory that
mysql used when IT was installed.  However, in order for
the compiler to be able to find the necessary header files,
you must enter "/usr/local/mysql" as the mysql install
directory.  Perhaps there is some way to specify that you
want the directory OF the mysql installation rather than the
directory INTO WHICH mysql was installed.

-"make install" will not work until a "make" has been
successfully completed.  I realize that jumping straight
to "make install" is the lazy way to install software, but
it should still work.  It chokes on an rm command, of all
things.

Fortunately I know enough about this stuff to make it work
right.  But you're doing yourselves a real disservice.  Your
software is too good to be thrown away by a less experienced
user who might give up after the first make error...

Jeff Morrow
jmorrow@alum.mit.edu

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [1998-05-21 13:35 UTC] rasmus
The 'make clean' problem has been fixed.  The LIBS line with all the trailing \'s has
also been fixed.  The MySQL dir thing you mention is not entirely correct.  The
default of /usr/local is correct when you install the binary distribution of MySQL.
The mysql.h file on my system is in /usr/local/include/mysql/mysql.h for example.
And finally, I am unable to reproduce that 'make install' problem you had.
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Sun Nov 28 00:03:13 2021 UTC