php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Doc Bug #35578 max size of the post_max_size variable in php.ini
Submitted: 2005-12-07 06:49 UTC Modified: 2005-12-07 06:50 UTC
From: khascall at uchicago dot edu Assigned:
Status: Not a bug Package: Documentation problem
PHP Version: Irrelevant OS: any
Private report: No CVE-ID:
 [2005-12-07 06:49 UTC] khascall at uchicago dot edu
Description:
------------
It seems that the post_max_size variable has a maximum of 
2047M -- setting it to 2048M or larger causes many bad things 
to happen, in particular it clobbers all of my POST data. I 
assume this is because if you are storing 2048M as an unsigned 
int and then treating it as an signed int later, the code is 
comparing the POST data size with a negative number. I felt so 
much pain and confusion before I found this! This should be 
documented and should probably cause an error of some kind. 
It's too late for you to save me -- please, save the others!


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2005-12-07 06:50 UTC] khascall at uchicago dot edu
aiee, how do I delete stuff
 
PHP Copyright © 2001-2014 The PHP Group
All rights reserved.
Last updated: Fri Apr 18 00:01:21 2014 UTC