php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Doc Bug #35527 brace escape problem ( continues? )
Submitted: 2005-12-02 22:58 UTC Modified: 2005-12-06 16:21 UTC
From: judas dot iscariote at gmail dot com Assigned: iliaa (profile)
Status: Closed Package: Documentation problem
PHP Version: 5CVS-2005-12-02 (CVS) OS: Linux
Private report: No CVE-ID: None
 [2005-12-02 22:58 UTC] judas dot iscariote at gmail dot com
Description:
------------
seems to be related to Bug #35411

but now the "\" char is displayed.


'../configure' '--prefix=/usr' '--datadir=/usr/share/php5' '--mandir=/usr/share/man' '--bindir=/usr/bin' '--libdir=/usr/lib64' '--includedir=/usr/include' '--with-libdir=lib64' '--sysconfdir=/etc/php5/apache2' '--with-config-file-path=/etc/php5/apache2' '--with-config-file-scan-dir=/etc/php5/conf.d' '--with-exec-dir=/usr/lib64/php5/bin' '--enable-magic-quotes' '--enable-libxml' '--enable-session' '--with-mm' '--with-pcre-regex' '--enable-xml' '--enable-simplexml' '--enable-spl' '--enable-safe-mode' '--enable-sigchild' '--disable-debug' '--enable-memory-limit' '--enable-inline-optimization' '--enable-zend-multibyte' '--with-apxs2=/usr/sbin/apxs2' '--disable-all'


Reproduce code:
---------------
Same as Bug #35411


Expected result:
----------------
php 5.0.5:

... abc ...
... {abc} ...

Actual result:
--------------
... abc ... 

... \{abc} ... 

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2005-12-03 01:57 UTC] sniper@php.net
# php t.php 
... abc ...
... \{abc} ...
# php -v
PHP 5.1.2-dev (cli) (built: Dec  3 2005 01:35:55) (DEBUG)
Copyright (c) 1997-2005 The PHP Group
Zend Engine v2.1.0, Copyright (c) 1998-2005 Zend Technologies

 [2005-12-03 02:03 UTC] iliaa@php.net
Thank you for taking the time to write to us, but this is not
a bug. Please double-check the documentation available at
http://www.php.net/manual/ and the instructions on how to report
a bug at http://bugs.php.net/how-to-report.php

This is expected behaviour, {} is no longer special, they are being treated like any other character.
 [2005-12-03 02:49 UTC] judas dot iscariote at gmail dot com
php t.php
... abc ...
... {abc} ...

PHP 4.3.10 (cli) (built: Nov 18 2005 00:58:42)
Copyright (c) 1997-2004 The PHP Group
Zend Engine v1.3.0, Copyright (c) 1998-2004 Zend Technologies

So.. another Backward incompatible change ??



it 's not mentioned in the upgrade Guide...
http://www.php.net/README_UPGRADE_51.php
 [2005-12-04 22:05 UTC] iliaa@php.net
This fixes a consistency bug found in older releases.
 [2005-12-06 16:21 UTC] vrana@php.net
This bug has been fixed in the documentation's XML sources. Since the
online and downloadable versions of the documentation need some time
to get updated, we would like to ask you to be a bit patient.

Thank you for the report, and for helping us make our documentation better.

"Before PHP 5.1.1, backslash in \{$var} hasn't been printed."

"(Use "{\$" to get a literal "{$")."
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Tue Oct 27 17:01:24 2020 UTC