php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Request #35510 [PATCH] ext/gmp: gmp_nextprime()
Submitted: 2005-12-01 20:13 UTC Modified: 2006-07-18 14:56 UTC
Votes:1
Avg. Score:5.0 ± 0.0
Reproduced:0 of 0 (0.0%)
From: ants dot aasma at gmail dot com Assigned:
Status: Closed Package: Feature/Change Request
PHP Version: 5.1.1 OS: Linux
Private report: No CVE-ID: None
 [2005-12-01 20:13 UTC] ants dot aasma at gmail dot com
Description:
------------
Add the gmp_nextprime function to ext/gmp. I need it for    
my cryptographically secure random number generator and    
it's probably pretty useful to others too (espescially  
because I can then release my code properly :).  
  
http://www.hot.ee/stepz/Math_Random/gmp.patch is the 
(really simple) patch. 

Reproduce code:
---------------
if (function_exists("gmp_nextprime")) {
echo gmp_strval(gmp_nextprime(1000));
} else {
echo "No function";
}

Expected result:
----------------
1009 

Actual result:
--------------
No function 

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2005-12-01 21:46 UTC] sniper@php.net
reclassified where this belongs.
 [2006-04-03 19:47 UTC] tony2001@php.net
Thank you for the patch.
Applied to HEAD (aka PHP6).
 [2006-07-18 14:56 UTC] tony2001@php.net
Patch committed to 5_2 branch too.
 
PHP Copyright © 2001-2024 The PHP Group
All rights reserved.
Last updated: Tue Mar 05 03:01:30 2024 UTC