php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #35499 strtotime with newline fails
Submitted: 2005-12-01 01:22 UTC Modified: 2005-12-01 17:26 UTC
Votes:1
Avg. Score:3.0 ± 0.0
Reproduced:1 of 1 (100.0%)
Same Version:1 (100.0%)
Same OS:1 (100.0%)
From: stabthecat at hotmail dot com Assigned: iliaa
Status: Closed Package: Date/time related
PHP Version: 5.1.1 OS: Windows / Linux
Private report: No CVE-ID:
 [2005-12-01 01:22 UTC] stabthecat at hotmail dot com
Description:
------------
Since version 5.1

strtotime("11/20/2005 8:00 AM\r\n"); 

fails, and returns null

strtotime(trim("11/20/2005 8:00 AM\r\n")); 

fixes it




Reproduce code:
---------------
print(strtotime("11/20/2005 8:00 AM\r\n")); 


Expected result:
----------------
1132488000


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2005-12-01 17:26 UTC] iliaa@php.net
This bug has been fixed in CVS.

Snapshots of the sources are packaged every three hours; this change
will be in the next snapshot. You can grab the snapshot at
http://snaps.php.net/.
 
Thank you for the report, and for helping us make PHP better.


 
PHP Copyright © 2001-2014 The PHP Group
All rights reserved.
Last updated: Wed Apr 23 14:02:33 2014 UTC