php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #35471 Oracle Instant Client fails to locate includes/libs
Submitted: 2005-11-29 11:46 UTC Modified: 2005-12-02 08:39 UTC
From: jeppe at arabuusimiehet dot com Assigned: tony2001
Status: Closed Package: OCI8 related
PHP Version: 5.1.1 OS: RHEL4 X86_64
Private report: No CVE-ID:
 [2005-11-29 11:46 UTC] jeppe at arabuusimiehet dot com
Description:
------------
When using Oracle Instant Client 10.2 on x86_64 the configure
script only tries the 'lib' dir, not 'lib64'.

OCISDKRPMINC=`echo "$PHP_OCI8_INSTANT_CLIENT" | sed -e 's!^/usr/lib/oracle/\(.*\)/client/lib[/]*$!/usr/include/oracle/\1/client!`'

If I change that line s/lib/lib64/ everything works fine.



Reproduce code:
---------------
./configure --with-oci8-instant-client=/usr/lib64/oracle/10.2.0.1/client/lib64

Expected result:
----------------
configure running thru ok.

Actual result:
--------------
checking Oracle Instant Client SDK header directory... configure: error: Oracle Instant Client SDK header files not found

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2005-11-29 11:59 UTC] tony2001@php.net
How did you install OIC and where did you get these packages?
 [2005-11-29 12:08 UTC] jeppe at arabuusimiehet dot com
Sorry to not include that info in the beginning.

Since Oracle does not provide x86_64 RPM's I used these:

http://freshrpms.net/docs/oracle/
 [2005-11-29 13:10 UTC] sniper@php.net
Did you install the -devel package(s)?
 [2005-11-29 13:14 UTC] sniper@php.net
This was missing:

--with-libdir=lib64 

And the oci config.m4 should use $PHP_LIBDIR instead of lib,
assigned to the maintainer.
 [2005-11-29 13:36 UTC] tony2001@php.net
First of all, please use new OCI8 from PECL instead of the bundled one. It was too late to add it to 5.1, but it'll appear in 5.1.2.

And regarding your problem: grab the sources at http://pecl.php.net/oci8, put them instead of your ext/oci8 and apply this patch: http://tony2001.phpclub.net/dev/tmp/oci8_lib64.diff
Run 
./buildconf --force 
and 
./configure --with-oci8=instantclient,/usr/lib64/oracle/10.2.0.1/client/lib64 
the patch should fix the issue.
 [2005-12-02 08:39 UTC] jeppe at arabuusimiehet dot com
This fixed it. Thanks.
 
PHP Copyright © 2001-2014 The PHP Group
All rights reserved.
Last updated: Sun Apr 20 08:02:33 2014 UTC