php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #35298 Access Violation Crash IIS 6
Submitted: 2005-11-19 22:19 UTC Modified: 2005-12-04 18:11 UTC
From: alacn dot uhahaa at gmail dot com Assigned:
Status: Not a bug Package: IIS related
PHP Version: 4.4.1 OS: Windows 2003
Private report: No CVE-ID: None
 [2005-11-19 22:19 UTC] alacn dot uhahaa at gmail dot com
Description:
------------
while recycling iis6 worker process when an user is uploading a file, php crash with access violation "zend timeout window: w3wp - read error at address 0x019052a5"

Reproduce code:
---------------
at php.ini
post_max_size = 1032M
upload_max_filesize = 1024M

while an user is uploading a file (post, upload form) (use a big file, so it wont end before we finish), open iis mmc, go to application pools, select the php pool (DefaultAppPool if you didnt change it), right click on it and recycle

im using Windows 2003, IIS6, php 4.4.1 isapi

Expected result:
----------------
it should recycle without crash

Actual result:
--------------
php crash with access violation
"zend timeout window: w3wp"
"read error at address 0x019052a5"


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2005-12-04 14:58 UTC] alacn dot uhahaa at gmail dot com
its not fixed on cvs yet, it happens both on php 4.4.1 and php5 series.

it happens when iis is recycling the process, iis tell php that it will free the library, php perform cleanup tasks and return, but, if zend timeout thread is running while this happens and php return before zend timeout thread end, it will crash, because the timeout thread will execute on a freed (unloaded) place.

this is causing "zend window timeout" error on windows 2003
(for both php5 and php4)
 [2005-12-04 18:11 UTC] sniper@php.net
We are aware of PHP's problems with stability under IIS and are working 
to rectify the problem. Unfortunatly your bug report does not contain any
extra useful information and we already have enough bug reports open about
this issue. If you can provide more detailed information such as a 
reproducable crash or a backtrace please do so and reopen this bug. 
Otherwise please keep trying new releases as we are working to resolve 
the problems on this platform
 
Thanks for your interest in PHP.


 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Tue Jun 18 14:01:26 2019 UTC