php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Request #35276 exploding_wordwrap
Submitted: 2005-11-18 14:46 UTC Modified: 2020-12-08 12:43 UTC
From: teunkloosterman at gmail dot com Assigned: cmb (profile)
Status: Closed Package: Strings related
PHP Version: 5.1.0RC5 OS: Irrelevant
Private report: No CVE-ID: None
 [2005-11-18 14:46 UTC] teunkloosterman at gmail dot com
Description:
------------
Maybe this function is usefull enough to implement into php

Reproduce code:
---------------
$value = explode("#BREAK#", wordwrap($value, $length, "#BREAK#", 1));

Expected result:
----------------
$value[0] = "Line #1";
$value[1] = "Line #2";
$value[2] = "Line #3";
$value[3] = "Line #4";
$value[4] = "Line #5";
$value[5] = "Line #6";


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2016-12-30 23:20 UTC] cmb@php.net
-Package: Feature/Change Request +Package: Strings related
 [2020-12-08 12:43 UTC] cmb@php.net
-Status: Open +Status: Closed -Assigned To: +Assigned To: cmb
 [2020-12-08 12:43 UTC] cmb@php.net
I don't think this would be a generally useful addition, since it
can be done with preg_slit().  If you, or anybody else, still want
to have this function in PHP, please forward your request to the
internals mailing list.
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Thu Jun 17 19:01:23 2021 UTC