php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #35263 Crash during IIS Restart
Submitted: 2005-11-17 15:18 UTC Modified: 2005-12-08 17:09 UTC
From: bke15 at gmx dot de Assigned:
Status: Not a bug Package: IIS related
PHP Version: 5.0.5 - 5.1RC6 OS: Windows2003
Private report: No CVE-ID: None
 [2005-11-17 15:18 UTC] bke15 at gmx dot de
Description:
------------
Hi

I am using PHP5 on a Windows2003 Server with IIS. When i restart the machine with installed and working php5.0.5 everything is fine. After putting VisualC++6.0 on the server i am getting Application Errors during restart. I have nothing changed so far.

What is installed :

- Win2003 Server
- IIS with ISAPI Extension
- PHP 5.0.5 original BIN Distri from php.net ISAPI
- Visual C++ 6.0

The Application Error occurs during iisrestart an says following :

Event Type: Error
Event Source: Application Error
Event Category: (100)
Event ID: 1000
Date: 17.11.2005
Time: 14:56:24
User: N/A
Computer: MYSERVER
Description:
Faulting application w3wp.exe, version 6.0.3790.1830, faulting module unknown, version 0.0.0.0, fault address 0x01c61628.



Reproduce code:
---------------
run iisreset after calling a simple php page from the server.

1. Call page with phpinfo()
2. type iisreset on commandprompt 
3. get the error in the log and as popup on screen

repeat steps 1-3 - you will get the error each time.


Expected result:
----------------
no error as without VC++

Actual result:
--------------
Application Error occurs - 

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2005-11-17 15:23 UTC] tony2001@php.net
>After putting VisualC++6.0 on the server i am getting
>Application Errors during restart.

What makes you think it's PHP problem, not a problem of MSVC?
 [2005-11-17 15:24 UTC] tony2001@php.net
Please try using this CVS snapshot:

  http://snaps.php.net/php5-latest.tar.gz
 
For Windows:
 
  http://snaps.php.net/win32/php5-win32-latest.zip


 [2005-11-17 15:32 UTC] bke15 at gmx dot de
I have quickly tested the lastest Version and it happens too.

Why do i think its not a VC6 Problem ?

Because this error can only be detected when this Tool is onboard. Otherwise Windows might ignore this error. Only when a valid development solution is installed the error is displayed. I have no idea if it is shown too if other development environments are installed.
 [2005-11-17 15:42 UTC] sniper@php.net
Report problems with VisualC++ to Microsoft. Not our problem.
(FYI: It works fine for me..)

 [2005-11-18 09:26 UTC] bke15 at gmx dot de
I think your solution is too quick. If i setup my machine with VC6 but without ISAPI Extension that Crash does not happen.

This crash happens only if PHP is installed. So there must be a reason why ...
 [2005-11-18 09:37 UTC] sniper@php.net
We are aware of PHP's problems with stability under IIS and are working 
to rectify the problem. Unfortunatly your bug report does not contain any
extra useful information and we already have enough bug reports open about
this issue. If you can provide more detailed information such as a 
reproducable crash or a backtrace please do so and reopen this bug. 
Otherwise please keep trying new releases as we are working to resolve 
the problems on this platform
 
Thanks for your interest in PHP.


 [2005-11-18 09:38 UTC] tony2001@php.net
Since you have the development enviornment there, why don't you provide something more than just a "fault address" ?
A backtrace with all details and a short reproduce script would be very useful.

 [2005-11-18 09:52 UTC] bke15 at gmx dot de
The crash happens during restart, when all Services of IIS are stopped. For that reason there is no script to provide. Because it does not happen when a script is called.

Try as follows.
- Start IIS : iisreset /start
- call any php Script for example <? echo "hello"; ?>
- restart IIS : iisreset

Now we get the error as POPUP on screen and in the eventlog.

This issue happens an all of our Testsystems when a Development Solution like VC6 or .NET is installed.

I have no debugbuild of PHP so i can't find the location where the crash happens. I only know that it happens when the service is stopped during restart.

So please check this out.
 [2005-11-18 10:04 UTC] tony2001@php.net
If you can provide more detailed information such as a 
reproducable crash or a backtrace please do so and reopen this bug. 
Otherwise please keep trying new releases as we are working to resolve the problems on this platform.
 [2005-11-18 10:37 UTC] bke15 at gmx dot de
My last try ...

I have tested now the following :

- Installed clean Windows 2003 Webedition
- Installed all Service Packs
- Installed Visual Studio .Net 2003 c++ only
- Installed PHP 5.0.5 ISAPI Extension
- Installed test.php in DOCROOT
<? echo "Hello"; ?>
- Called the script twice via webbrowser
- IISRESET - no error
- Called the script again via webbrowser
- IISRESET - Application error during restart.

If you give this a try you will see the same. It may not happen each time, but nearly each ... so please give it a try 

otherwise - i will not reopen this bug ...
 [2005-11-18 10:39 UTC] sniper@php.net
It still works fine for me.
 [2005-11-23 17:15 UTC] bke15 at gmx dot de
You asked me to send more Information on that crash. I used iisstate to monitor the w3p service. I got this during restart:

Opened log file 'C:\iisstate\output\IISState-3940.log'

***********************
Starting new log output
IISState version 3.3.1 

Wed Nov 23 17:10:14 2005

OS = Windows 2003 Server
Executable: w3wp.exe
PID =  3940

Note: Thread times are formatted as HH:MM:SS.ms

***********************

IIS has crashed...
Beginning Analysis
DLL (!FunctionName) that failed: 

Thread ID: 13
System Thread ID: f3c
Kernel Time: 0:0:0.15
User Time: 0:0:0.0
Thread Type: Other 
 # ChildEBP RetAddr  
00 01ddff5c 00000000 0x18880b5
Closing open log file C:\iisstate\output\IISState-3940.log
Opened log file 'C:\iisstate\output\IISState-3940.log'

***********************
Starting new log output
IISState version 3.3.1 

Wed Nov 23 17:10:14 2005

OS = Windows 2003 Server
Executable: w3wp.exe
PID =  3940

Note: Thread times are formatted as HH:MM:SS.ms

***********************

Thread ID: 0
System Thread ID: 128
Kernel Time: 0:0:0.125
User Time: 0:0:0.46

Ask me if you need more Information than that.
 [2005-11-23 17:37 UTC] bke15 at gmx dot de
This issue appears in all Versions of PHP from 5.0.5 to 5.1RC6
 [2005-11-23 20:25 UTC] tony2001@php.net
Sorry, there is zero useful information in your post.
A backtrace would be useful, but those log entries do not provide any helpful info.
 [2005-12-08 15:37 UTC] bke15 at gmx dot de
2 Updates on that issue :

1. I found out, that this issue only happens if you are using IIS6 having not checked "use IIS5 Isolation Mode". I addition you can see a 
If used in "IIS5 Isolation Mode" everything is fine. We need to have this mode disabled. 

2. On a simple Windwos2004 Webediton without Debugger installed you can view this error in the systemlog too: I get this:
A process serving application pool 'test_3' terminated unexpectedly. 
The process id was '3588'. The process exit code was '0xc0000005'.


If you can't reproduce this - please mail me a webpage where i can read in detail how to create a dump that is useful for you to trace.

Many thanx
 [2005-12-08 17:09 UTC] sniper@php.net
We are aware of PHP's problems with stability under IIS and are working 
to rectify the problem. Unfortunatly your bug report does not contain any
extra useful information and we already have enough bug reports open about
this issue. If you can provide more detailed information such as a 
reproducable crash or a backtrace please do so and reopen this bug. 
Otherwise please keep trying new releases as we are working to resolve 
the problems on this platform
 
Thanks for your interest in PHP.


 
PHP Copyright © 2001-2023 The PHP Group
All rights reserved.
Last updated: Wed Feb 08 07:03:40 2023 UTC