php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #35158 binding of stored proc input parameters is not working
Submitted: 2005-11-08 20:09 UTC Modified: 2005-11-18 21:22 UTC
Votes:2
Avg. Score:5.0 ± 0.0
Reproduced:0 of 0 (0.0%)
From: vladik_g at mail dot ru Assigned: fmk (profile)
Status: Closed Package: MSSQL related
PHP Version: 5CVS-2005-11-08 (snap) OS: Linux RedHat 9
Private report: No CVE-ID: None
 [2005-11-08 20:09 UTC] vladik_g at mail dot ru
Description:
------------
binding input parameters is not really working.

This mechanism was working well in 4-th family of php.

Reproduce code:
---------------
php code here:

mssql_bind($Proc,'@Param1',$Param1,SQLVARCHAR,false,false,30); mssql_execute($Proc,FALSE) ||
  print(mssql_get_last_message());

MSSQL code here:

CREATE PROCEDURE [dbo].[test]
(
	@Param1              VARCHAR(30)
)

AS
RETURN 0
GO


Expected result:
----------------
successfull execution

Actual result:
--------------
Procedure 'test' expects parameter '@Param1', which was not supplied.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2005-11-08 20:29 UTC] sniper@php.net
What else have changed for you except for PHP version?
 [2005-11-09 11:14 UTC] vladik_g at mail dot ru
Nothing more.
With php 4.4 on same machine with same other soft all works ok.
 [2005-11-09 12:55 UTC] sniper@php.net
Frank, check this out please.
 [2005-11-14 15:09 UTC] vladik_g at mail dot ru
Frank, is there any chance to get it working shortly?
 [2005-11-18 21:22 UTC] fmk@php.net
This is fixed in freetds v0.63.dev (the CVS version).
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Sun Jan 23 20:03:35 2022 UTC