|  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #35078 configure does not find ldap_start_tls_s
Submitted: 2005-11-03 04:50 UTC Modified: 2005-11-03 21:42 UTC
From: bkw at weisshuhn dot de Assigned:
Status: Closed Package: Compile Failure
PHP Version: 5CVS, 4CVS OS: Linux Fedora Core 2,3,4
Private report: No CVE-ID:
 [2005-11-03 04:50 UTC] bkw at weisshuhn dot de
Actually a regression of Bug #24025:

configure fails to find ldap_parse_result, ldap_parse_reference and ldap_start_tls_s.

this patch fixes the problem, which was introduced in Version Version 1.26.28 of ext/ldap/config.m4:

--- php-4.4.11/ext/ldap/config.m4.ldapconf
+++ php-4.4.11/ext/ldap/config.m4
@@ -124,6 +125,8 @@ if test "$PHP_LDAP" != "no"; then

   dnl Solaris 2.8 claims to be 2004 API, but doesn't have
   dnl ldap_parse_reference() nor ldap_start_tls_s()
   AC_CHECK_FUNCS([ldap_parse_result ldap_parse_reference ldap_start_tls_s])

The commit that introduced the behaviour:
The LDAP_SHARED_LIBADD was lost from LDFLAGS by the rearrangement there.


Add a Patch

Pull Requests

Add a Pull Request


AllCommentsChangesGit/SVN commitsRelated reports
 [2005-11-03 04:58 UTC] bkw at weisshuhn dot de
The sersion of ext/ldap/config.m4 that introduced the regression is,  not .28 as stated above ;-)

Also, the line numbers of the patch may be slightly off, since  I already applied another (unrelated) patch before, sorry about that. But it's probably obvious anyway.
 [2005-11-03 21:42 UTC]
This bug has been fixed in CVS.

Snapshots of the sources are packaged every three hours; this change
will be in the next snapshot. You can grab the snapshot at
Thank you for the report, and for helping us make PHP better.

PHP Copyright © 2001-2015 The PHP Group
All rights reserved.
Last updated: Wed Nov 25 18:01:40 2015 UTC