|  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #34987 crashes during startup with --with-mssql
Submitted: 2005-10-26 09:56 UTC Modified: 2005-11-17 16:43 UTC
From: michal_czerniak at o2 dot pl Assigned:
Status: Not a bug Package: MSSQL related
PHP Version: 5CVS-2005-11-17 (snap) OS: AIX 5.2L
Private report: No CVE-ID: None
 [2005-10-26 09:56 UTC] michal_czerniak at o2 dot pl
I'm trying to build php with mssql support. 
I've tried almost all possible combinations of 
arguments, but after successfull compilation apache segfaults. 
My last try was with apache 1.3.34 (I have tried with 1.3.32,33, 
./configure --enable-module=so 
make install 
-OK, runs fine 
php5-200510200830 (prievously almost all versions from 4.3 to 5.1RC): 
./configure --prefix=/usr/local/php51 
--with-apxs=/usr/local/apache/bin/apxs --with-mssql=/usr/local/freetds 
make instal 
root /usr/local/apache/bin > ./apachectl start 
./apachectl[86]: 311404 Segmentation fault(coredump) 
./apachectl start: httpd could not be started 

When I remove freetds from php configuration, everything works fine. 
Freetds tested manualy from command line also works fine.


Add a Patch

Pull Requests

Add a Pull Request


AllCommentsChangesGit/SVN commitsRelated reports
 [2005-11-17 14:59 UTC] michal_czerniak at o2 dot pl
Still not working:
psaix root /usr/apachessl/bin > gdb httpd
GNU gdb 6.2.1
Copyright 2004 Free Software Foundation, Inc.
GDB is free software, covered by the GNU General Public License, and you are
welcome to change it and/or distribute copies of it under certain conditions.
Type "show copying" to see the conditions.
There is absolutely no warranty for GDB.  Type "show warranty" for details.
This GDB was configured as "powerpc-ibm-aix5.1.0.0"...
(gdb) run -X
Starting program: /usr/apachessl/bin/httpd -X

Program received signal SIGSEGV, Segmentation fault.
[Switching to Thread 1]
0xd127d4a8 in tds_alloc_context ()
   from /usr/local/freetds/lib/libsybdb.a(
(gdb) bt
#0  0xd127d4a8 in tds_alloc_context ()
   from /usr/local/freetds/lib/libsybdb.a(
#1  0xd12794ec in dbinit ()
   from /usr/local/freetds/lib/libsybdb.a(
#2  0xd41bc1a4 in zm_startup_mssql (type=1, module_number=13)
    at /usr/ins/php5-200511171130/ext/mssql/php_mssql.c:297
#3  0xd3f2d5cc in zend_startup_module_ex (module=0x2022a858)
    at /usr/ins/php5-200511171130/Zend/zend_API.c:1320
#4  0xd3f1a344 in zend_hash_apply (ht=0x2015ab98,
    apply_func=@0x20137c54: 0xd3f2d47c <zend_startup_module_ex>)
    at /usr/ins/php5-200511171130/Zend/zend_hash.c:664
#5  0xd3f2d7bc in zend_startup_modules ()
    at /usr/ins/php5-200511171130/Zend/zend_API.c:1367
#6  0xd401f944 in php_module_startup (sf=0x2013bce0,
    additional_modules=0x20133d9c, num_additional_modules=1)
    at /usr/ins/php5-200511171130/main/main.c:1533
#7  0xd41f2f68 in php_apache_startup (sapi_module=0x7)
    at /usr/ins/php5-200511171130/sapi/apache/mod_php5.c:270
#8  0xd41f44b0 in php_init_handler (s=0x7, p=0x202b8b98)
    at /usr/ins/php5-200511171130/sapi/apache/mod_php5.c:918
#9  0x1001cf24 in ap_init_modules ()
#10 0x10008428 in main ()
 [2005-11-17 15:34 UTC]
What freetds version? And you don't load any shared extensions in the php.ini?
 [2005-11-17 16:22 UTC] michal_czerniak at o2 dot pl
I'm using (trying to use..) FreeTDS 0.63 (
I do not have any additional extensions.
 [2005-11-17 16:43 UTC]
Please contact IBM support. This is not an AIX support channel.
PHP Copyright © 2001-2024 The PHP Group
All rights reserved.
Last updated: Sun Jun 23 14:01:30 2024 UTC