php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #34889 PHP Startup: Unable to load dynamic library "......\php\php_curl.dll".
Submitted: 2005-10-17 15:18 UTC Modified: 2005-10-17 15:33 UTC
From: rinkesh dot p at directi dot com Assigned:
Status: Not a bug Package: Apache2 related
PHP Version: 5.1.0RC1 OS: Windows XP Proffessional
Private report: No CVE-ID: None
 [2005-10-17 15:18 UTC] rinkesh dot p at directi dot com
Description:
------------
PHP Version: PHP 5.1.0 and PHP 5.0.0 (Tried Both Versions)
OS: Windows XP (Professional and HOme Edition) Tried
Web Server: Apache2

I have configured apache2 and php5.1.0 very well.
But when i tried to load extensions like curl, soap, etc for PHP5.1 i got following error:

- 'PHP Startup: Unable to load dynamic library "......\php\php_curl.dll" - The specified module could not be found.'

I cofigured mysql,mssql,mysqli,xml-rpc and its working perfactly but for some modules i am getting above error twice when i restart or start my apache 2 server.

I have all "DLLs" required to load error modules which are latest downloads from php.net website.

Please help me in configuring same.

thanks.

Expected result:
----------------
I want my all moduled running w/o error.


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2005-10-17 15:33 UTC] tony2001@php.net
Sorry, but your problem does not imply a bug in PHP itself.  For a
list of more appropriate places to ask for help using PHP, please
visit http://www.php.net/support.php as this bug system is not the
appropriate forum for asking support questions.  Due to the volume
of reports we can not explain in detail here why your report is not
a bug.  The support channels will be able to provide an explanation
for you.

Thank you for your interest in PHP.

http://php.net/curl says:
"Note to Win32 Users: In order to enable this module on a Windows environment, you must copy libeay32.dll and ssleay32.dll from the DLL folder of the PHP/Win32 binary package to the SYSTEM folder of your Windows machine. (Ex: C:\WINNT\SYSTEM32 or C:\WINDOWS\SYSTEM)"
 
PHP Copyright © 2001-2017 The PHP Group
All rights reserved.
Last updated: Sun Nov 19 01:31:42 2017 UTC