php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #3487 get_browser() segfaults
Submitted: 2000-02-15 18:11 UTC Modified: 2002-10-01 14:41 UTC
Votes:1
Avg. Score:3.0 ± 0.0
Reproduced:0 of 0 (0.0%)
From: eric at emergencypuffjacket dot com Assigned:
Status: Wont fix Package: Reproducible Crash
PHP Version: 3.0.12 OS: BSD/OS 3.1
Private report: No CVE-ID: None
Have you experienced this issue?
Rate the importance of this bug to you:

 [2000-02-15 18:11 UTC] eric at emergencypuffjacket dot com
I am using mod_php3-3.0.12-module-mysql-imap-gd.so with Apache 1.2.6
If I call get_browser() I get a segfault error logged to the apache error log.
I do not actually get a core file, and if I turn on php-logging I get nothing there as well.
I am setting my php config vars via the apache httpd.conf file like this:
  php3_browscap /usr/local/etc/httpd/browscap.ini
and I am using the latest file from cyscape.

One interesting note: if I comment out the browscap config variable get_browser() returns an empty array. If I put it in the segfaults every time.

I won't add a code listing since his bug is the virtually identical to bugs 970, 2348, 3016 and 3481.

I would urge someone to look at this one; this bug crosses all platforms and is reported as early as 3.0.5.
Parsing a file isn't really a brain-buster. Perhaps the browser.ini should be converted to XML and a quick parser library put in place?  Just a suggestion.  
If I was a C coder I would do it myself... if only it were Java.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2002-10-01 14:41 UTC] hholzgra@php.net
We are sorry, but can not support PHP 3 related problems anymore.
Momentum is gathering for PHP 5, and we think supporting PHP 3 will
lead to a waste of resources which we want to put into getting PHP 5
ready. Ofcourse PHP 4 will will continue to be supported for the
forseeable future.

actualy believed to be fixed even for php3
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Tue Jul 23 22:01:28 2019 UTC