php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #34856 Bug with ICONV #32244 still open
Submitted: 2005-10-13 14:36 UTC Modified: 2005-10-13 17:24 UTC
Votes:1
Avg. Score:5.0 ± 0.0
Reproduced:1 of 1 (100.0%)
Same Version:0 (0.0%)
Same OS:1 (100.0%)
From: begemot at php dot com dot ua Assigned:
Status: Closed Package: ICONV related
PHP Version: 5.1.0RC1 OS: FreeBSD 5.4-RELEASE
Private report: No CVE-ID:
 [2005-10-13 14:36 UTC] begemot at php dot com dot ua
Description:
------------
Pleas reopen bug http://bugs.php.net/bug.php?id=32244
Get version from http://snaps.php.net/php5-200510131030.tar.bz2

configure options

>cat myconfigure
#!/bin/sh
./configure  --with-apxs2  --with-layout   --with-libxml-dir  --with-zlib  --enable-bcmath  --with-bz2  --with-curl  --enable-ftp  --with-gd  --with-jpeg-dir  --with-png-dir  --with-xpm-dir  --with-ttf  --with-freetype-dir  --with-t1lib  --enable-gd-native-ttf  --with-gettext  --with-mcrypt  --with-mhash --with-mysql=/usr/local  --with-mysqli=/usr/local/bin/mysql_config  --with-ncurses  --enable-sockets  --enable-sqlite-utf8  --with-xmlreader  --with-xsl  --without-pear --with-iconv --with-pdo-mysql=/usr/local --enable-mbstring

>php -v
PHP 5.1.0RC2-dev (cli) (built: Oct 13 2005 15:14:18)
Copyright (c) 1997-2005 The PHP Group
Zend Engine v2.1.0-dev, Copyright (c) 1998-2005 Zend Technologies

Reproduce code:
---------------
<?php
        var_dump(get_extension_funcs("iconv"));
?>

>php test.php
array(11) {
  [0]=>
  string(8) "libiconv"
  [1]=>
  string(16) "ob_iconv_handler"
  [2]=>
  string(18) "iconv_get_encoding"
  [3]=>
  string(18) "iconv_set_encoding"
  [4]=>
  string(12) "iconv_strlen"
  [5]=>
  string(12) "iconv_substr"
  [6]=>
  string(12) "iconv_strpos"
  [7]=>
  string(13) "iconv_strrpos"
  [8]=>
  string(17) "iconv_mime_encode"
  [9]=>
  string(17) "iconv_mime_decode"
  [10]=>
  string(25) "iconv_mime_decode_headers"
}


array
  0 => 'libiconv'
  1 => 'ob_iconv_handler'
  2 => 'iconv_get_encoding'
  3 => 'iconv_set_encoding'
  4 => 'iconv_strlen'
  5 => 'iconv_substr'
  6 => 'iconv_strpos'
  7 => 'iconv_strrpos'
  8 => 'iconv_mime_encode'
  9 => 'iconv_mime_decode'
  10 => 'iconv_mime_decode_headers'





Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2005-10-13 16:13 UTC] tony2001@php.net
Can't reproduce.

FreeBSD 5.4-STABLE
libiconv-1.9.1_3
PHP 5.1.0RC2-dev (cli) (built: Oct 13 2005 14:14:17) (DEBUG)

./sapi/cli/php -r 'var_dump(get_extension_funcs("iconv"));'
array(11) {
  [0]=>
  string(5) "iconv"
...
 [2005-10-13 16:19 UTC] begemot at php dot com dot ua
libiconv-1.9.2_1

begemot@angel[p0]/usr/home/begemot/php5-200510131030>./sapi/cli/php -r 'var_dump(get_extension_funcs("iconv"));'
array(11) {
  [0]=>
  string(8) "libiconv"
...
 [2005-10-13 16:24 UTC] tony2001@php.net
How can *I* reproduce it?
 [2005-10-13 17:24 UTC] tony2001@php.net
This bug has been fixed in CVS.

Snapshots of the sources are packaged every three hours; this change
will be in the next snapshot. You can grab the snapshot at
http://snaps.php.net/.
 
Thank you for the report, and for helping us make PHP better.


 
PHP Copyright © 2001-2014 The PHP Group
All rights reserved.
Last updated: Sat Apr 19 01:01:59 2014 UTC