php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #34756 PDOExceptions aren't derived from Exception which will cause a Fatal error
Submitted: 2005-10-06 13:59 UTC Modified: 2005-10-06 16:02 UTC
From: spheroid@php.net Assigned: helly (profile)
Status: Not a bug Package: PDO related
PHP Version: 5CVS-2005-10-06 (CVS) OS: Mac OS X 10.4
Private report: No CVE-ID: None
 [2005-10-06 13:59 UTC] spheroid@php.net
Description:
------------
The summary says it all. I upgraded to RC2-dev and noticed that if something goes wrong and PDO::ERRMODE_EXCEPTION is set I get a Fatal error.

Reproduce code:
---------------
<?php
$pdo = New PDO(...);
$pdo->setAttribute(PDO::ATTR_ERRMODE, PDO::ERRMODE_EXCEPTION);
$pdo->query("SELECT FROM");
?>

Expected result:
----------------
Exception thrown as usual.

Actual result:
--------------
PHP Fatal error:  Exceptions must be valid objects derived from the Exception base class in ...

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2005-10-06 14:17 UTC] tony2001@php.net
Can't reproduce.
What was your ./configure line ?
 [2005-10-06 14:58 UTC] spheroid@php.net
Configure line goes here:

./configure --prefix=/usr/local --with-apxs2=/usr/local/bin/apxs --disable-cgi --enable-mbstring --with-zlib --with-pdo-mysql --with-pdo-pgsql=/opt/local/lib/pgsql8 --with-ldap --with-pgsql --with-mysql --with-mssql=/opt/local --with-pdo-dblib=/opt/local --without-pear

I tested this with RC1 and it works as expected but I get the error on RC2-dev. I talked with Derick earlier today and he verified that he has noticed the same behavior as well.
 [2005-10-06 15:13 UTC] sniper@php.net
Marcus, if I understood correctly, you had something to do with this. :)

 [2005-10-06 16:00 UTC] spheroid@php.net
My bad!

I should've compiled a more recent version before posting the report. That one I was running was from yesterday - trying with most recent snapshot it works like a charm.
 [2005-10-06 16:02 UTC] spheroid@php.net
Thank you for taking the time to report a problem with PHP.
Unfortunately you are not using a current version of PHP -- 
the problem might already be fixed. Please download a new
PHP version from http://www.php.net/downloads.php

If you are able to reproduce the bug with one of the latest
versions of PHP, please change the PHP version on this bug report
to the version you tested and change the status back to "Open".
Again, thank you for your continued support of PHP.


 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Thu Nov 26 00:01:22 2020 UTC