php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #34583 When compiling without --without-pear install silently fails
Submitted: 2005-09-21 17:06 UTC Modified: 2005-09-22 15:04 UTC
From: mike at blueroot dot co dot uk Assigned:
Status: Closed Package: Compile Failure
PHP Version: 5CVS-2005-09-21 (snap) OS: Linux 2.6 Fedora 2
Private report: No CVE-ID: None
 [2005-09-21 17:06 UTC] mike at blueroot dot co dot uk
Description:
------------
When installing 5.1.0-RC2-dev (snap) it says that PEAR was not installed and gives instructions to install.

What it doesnt say is that it installed mod_php into your apache directory, but didnt install the helper applications (and probably a few other things)

Reproduce code:
---------------
# cd php-5.0.5
...
# make install
...
# phpize -v 
Configuring for:
PHP Api Version:         20031224
Zend Module Api No:      20041030
Zend Extension Api No:   220040412

# cd php5-200509211230
# ./configure && make && make install
......
Installing PHP SAPI module:       apache
[activating module `php5' in /www/conf/httpd.conf]
cp libs/libphp5.so /www/libexec/libphp5.so
chmod 755 /www/libexec/libphp5.so
cp /www/conf/httpd.conf /www/conf/httpd.conf.bak
cp /www/conf/httpd.conf.new /www/conf/httpd.conf
rm /www/conf/httpd.conf.new
Installing PHP CLI binary:        /php5/bin/
Installing PHP CLI man page:      /php5/man/man1/
Installing shared extensions:     /php5/lib/php/extensions/no-debug-non-zts-20050617/
Installing PEAR environment:      /php5/lib/php/
+----------------------------------------------------------------------+
| The installation process is incomplete. The following resources were |
| not installed:                                                       |
|                                                                      |
|   PEAR: PHP Extension and Application Repository                     |
|                                                                      |
| To install these components,                                         |
| download http://pear.php.net/install-pear.phar to php-src/pear/      |
| become the superuser and execute:                                    |
|                                                                      |
|   # make install-su                                                  |
+----------------------------------------------------------------------+
make: *** [install-pear] Error 5

# /php5/bin/phpize -v


Configuring for:
PHP Api Version:         20031224
Zend Module Api No:      20041030
Zend Extension Api No:   220040412

Expected result:
----------------
The above shows that the php helper apps didnt get installed properly, which causes all sorts of hidden problems.

It says the installation process was incomplete, but part was completed.  Is this just a warning, or does it represent an error?  Surely it should just show a warning.


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2005-09-21 23:16 UTC] sniper@php.net
Yet-another-bug caused by the crap called PEAR..
 [2005-09-22 15:04 UTC] sniper@php.net
This bug has been fixed in CVS.

Snapshots of the sources are packaged every three hours; this change
will be in the next snapshot. You can grab the snapshot at
http://snaps.php.net/.
 
Thank you for the report, and for helping us make PHP better.


 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Sat Apr 20 00:01:25 2019 UTC