php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Request #34557 php -m exits with "error" 1
Submitted: 2005-09-20 09:33 UTC Modified: 2005-10-06 22:40 UTC
Votes:1
Avg. Score:3.0 ± 0.0
Reproduced:1 of 1 (100.0%)
Same Version:0 (0.0%)
Same OS:0 (0.0%)
From: glen at delfi dot ee Assigned:
Status: Closed Package: Feature/Change Request
PHP Version: 5.0.5 OS: PLD Linux
Private report: No CVE-ID:
 [2005-09-20 09:33 UTC] glen at delfi dot ee
Description:
------------
php -m is documented as:  
  -m               Show compiled in modules  
  
request to change it to exit 0, if there's no particular  
reason it to be 1.  
  
for example:  
in a schell script, which has "set -e" enabled, and running  
"php -m" terminates the script. the "error" exit code is  
really unexpected, because there's no errors (at least if 
there were they weren't printed). 
 
 
  

Reproduce code:
---------------
$ php -m; echo EXIT: $?
[PHP Modules]
bcmath
ftp
libxml
mhash
pcre
radius
session
SimpleXML
SPL
standard
tokenizer
xml
zlib

[Zend Modules]

EXIT: 1



Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2005-10-06 22:40 UTC] johannes@php.net
This bug has been fixed in CVS.

Snapshots of the sources are packaged every three hours; this change
will be in the next snapshot. You can grab the snapshot at
http://snaps.php.net/.
 
Thank you for the report, and for helping us make PHP better.


 
PHP Copyright © 2001-2014 The PHP Group
All rights reserved.
Last updated: Wed Apr 23 07:02:14 2014 UTC