php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #34545 TIMECOND_IFMODSINCE not implemented for many years???
Submitted: 2005-09-19 01:28 UTC Modified: 2005-09-20 07:22 UTC
From: mshonich at yandex dot ru Assigned:
Status: Not a bug Package: cURL related
PHP Version: 4.4.0 OS: any
Private report: No CVE-ID: None
 [2005-09-19 01:28 UTC] mshonich at yandex dot ru
Description:
------------
Docs `bout curl_setopt notice the CURLOPT_TIMECOND and CURLOPT_TIMEVALUE options. Specifically:

<i>CURLOPT_TIMEVALUE: Pass a long as a parameter that is the time in seconds since January 1st, 1970. The time will be used as specified by the CURLOPT_TIMEVALUE option, or by default the TIMECOND_IFMODSINCE will be used. </i>

First of all, documentation is confusing: IMHO it should be read <i>The time will be used as specified by the CURLOPT_TIMECOND option, or by default the TIMECOND_IFMODSINCE will be used. </i>

Second, it is completely wrong: If you only specify CURLOPT_TIMEVALUE without CURLOPT_TIMECOND, then nothing will happen - If-Modified-Since header won't be send. Thus default behaviour is not TIMECOND_IFMODSINCE.

Next big thing about this bug is that TIMECOND_IFMODSINCE was never defined for astonishing high number of major releases. One can use curl_setopt(CURLOPT_TIMECOND, 1) as a workaround, but it is darn unconvient.



Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2005-09-19 08:27 UTC] sniper@php.net
I don't know what version you actually have tried, but CURL_TIMECOND_IFMODSINCE has existed since 4.3.9..

 [2005-09-20 07:22 UTC] mshonich at yandex dot ru
So, is it all about documentation being incorrect once (no "CURL_" prefix before TIMECOND_IFMODSINCE) or twice (also default behaviour is not TIMECODE_IFMODSINCE as it is described)? If so, better move this bug to "docs" cathegory.
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Fri Aug 23 05:01:27 2019 UTC