php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #34523 pdo drivers are not compiled due to compilation errors
Submitted: 2005-09-16 09:11 UTC Modified: 2005-09-22 16:33 UTC
From: dan at yes dot lt Assigned: edink (profile)
Status: Closed Package: PDO related
PHP Version: 5CVS-2005-09-16 (snap) OS: windows
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: dan at yes dot lt
New email:
PHP Version: OS:

 

 [2005-09-16 09:11 UTC] dan at yes dot lt
Description:
------------
PDO drivers are not compiled due to compilation errors

Some lines from http://snaps.php.net/win32/snapshot-5.1.log

ext\pdo_dblib\dblib_driver.c(250) : error C2198: 'php_pdo_get_exception' : too few actual parameters
ext\pdo_mysql\mysql_driver.c(100) : error C2198: 'php_pdo_get_exception' : too few actual parameters
ext\pdo_oci\oci_driver.c(161) : error C2198: 'php_pdo_get_exception' : too few actual parameters
ext\pdo_odbc\odbc_driver.c(90) : error C2198: 'php_pdo_get_exception' : too few actual parameters
ext\pdo_pgsql\pgsql_driver.c(83) : error C2198: 'php_pdo_get_exception' : too few actual parameters
ext\pdo_sqlite\sqlite_driver.c(78) : error C2198: 'php_pdo_get_exception' : too few actual parameters
ext\pdo_sqlite\sqlite_driver.c(695) : error C2198: 'php_pdo_get_exception' : too few actual parameters




Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2005-09-16 10:01 UTC] sniper@php.net
This is either caused by the build machine using outdated sources/headers or mixing some PDO stuff from PECL and some from the core..or wrong branch?

 [2005-09-19 14:07 UTC] sniper@php.net
See also bug #34255

 [2005-09-22 16:33 UTC] edink@php.net
This bug has been fixed in CVS.

Snapshots of the sources are packaged every three hours; this change
will be in the next snapshot. You can grab the snapshot at
http://snaps.php.net/.
 
Thank you for the report, and for helping us make PHP better.


 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Sun Sep 19 15:03:37 2021 UTC