php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #34512 libphp5.so doesn't get built if --with-mysqli option is set
Submitted: 2005-09-15 15:15 UTC Modified: 2005-09-16 11:25 UTC
From: dar_tay at hotmail dot com Assigned:
Status: Closed Package: MySQLi related
PHP Version: 5CVS-2005-09-15 (snap) OS: Linux version 2.6.8-2-386
Private report: No CVE-ID: None
 [2005-09-15 15:15 UTC] dar_tay at hotmail dot com
Description:
------------
If configure with this everything is fine, I get a libphp5.so file

./configure \
--disable-all \
--with-apxs2=/usr/bin/apxs2 \

whereas, if I do this...

./configure \
--disable-all \
--with-apxs2=/usr/bin/apxs2 \
--with-mysqli=/usr/local/mysql/bin/mysql_config \

I don't get a libphp5.so file.

I get no warnings at the linking stage, everything seems to have worked, but I get a libphp.a instead.

mysql is the binary install from the mysql site (mysql-max-5.0.10-beta-linux-i686)

Apache is 2.0.54-5 .deb package

I am using the CVS snap from this morning.


Expected result:
----------------
a libphp5.so file


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2005-09-15 15:26 UTC] sniper@php.net
1) Where do you get the libphp5.a?
2) Did you do 'make install' ?
3) Do you have the mysql shared libs installed?
4) And the devel packages? 
5) What does this output:
# /usr/local/mysql/bin/mysql_config --libs

 [2005-09-15 15:35 UTC] dar_tay at hotmail dot com
1) libphp5.a appears in the libs directory alongside the libphp5.la file

2) I have tried it with both 'make' and 'make install', in this particular instance I simply used 'make' for both tests, with a 'make clean' inbetween.  First test produces the .so second test doesn't, I have tried this several times and I have even tried it by extracting from the .tar file each time 

3) mysql shared libs reside in /usr/local/mysql/lib/

4) devel packages? do you mean the headers? in /usr/local/mysql/include/

5) -L/usr/local/mysql/lib -lmysqlclient -lz -lcrypt -lnsl -lm -lc -lnss_files -lnss_dns -lresolv -lc -lnss_files -lnss_dns -lresolv

I've done it without args as well just incase that helps...

#  /usr/local/mysql/bin/mysql_config       
Usage: /usr/local/mysql/bin/mysql_config [OPTIONS]
Options:
        --cflags         [-I/usr/local/mysql/include -mcpu=pentiumpro]
        --include        [-I/usr/local/mysql/include]
        --libs           [-L/usr/local/mysql/lib -lmysqlclient -lz -lcrypt -lnsl -lm -lc -lnss_files -lnss_dns -lresolv -lc -lnss_files -lnss_dns -lresolv]
        --libs_r         [-L/usr/local/mysql/lib -lmysqlclient_r -lz -lpthread -lcrypt -lnsl -lm -lpthread -lc -lnss_files -lnss_dns -lresolv -lc -lnss_files -lnss_dns -lresolv]
        --socket         [/tmp/mysql.sock]
        --port           [3306]
        --version        [5.0.10-beta]
        --libmysqld-libs [-L/usr/local/mysql/lib -lmysqld -lpthread -lcrypt -lnsl -lm -lpthread -lc -lnss_files -lnss_dns -lresolv -lc -lnss_files -lnss_dns -lresolv -lrt]
 [2005-09-15 16:57 UTC] dar_tay at hotmail dot com
Just tried it against the latest mysql5 binary (mysql-max-5.0.12-beta-linux-i686) and got the same result.
 [2005-09-15 16:59 UTC] sniper@php.net
Can you please try with Mysql 4.1.x ? And send me the Makefile you have when the build fails to sniper@php.net

 [2005-09-15 17:49 UTC] dar_tay at hotmail dot com
Tried against mysql4 binary (mysql-max-4.1.14-pc-linux-gnu-i686) and resulting Makefile sent via email.
 [2005-09-15 19:36 UTC] sniper@php.net
Can you try the non-max mysql package instead?

 [2005-09-15 19:39 UTC] sniper@php.net
In what OS are you compiling..?
You are using the PHP 5.1 snashot???

 [2005-09-15 19:40 UTC] dar_tay at hotmail dot com
Debian GNU Linux 2.6.8-2-386

and I'm using the 5.1 snap from this morning
 [2005-09-15 19:41 UTC] sniper@php.net
And what MPM is Apache2 using???

 [2005-09-15 19:41 UTC] dar_tay at hotmail dot com
MPM is prefork model
 [2005-09-15 19:47 UTC] sniper@php.net
Why don't you have gawk installed? Please install it..
Another thing to try: Compile Apache2 yourself! The CFLAGS debian build has used are really weird considering you're using prefork MPM.

Another thing going wrong is the host detection. What does this output (run in the source directory):

# sh config.guess

 [2005-09-15 19:47 UTC] sniper@php.net
Another thing: exactly WHAT Debian is it?
 [2005-09-15 20:06 UTC] dar_tay at hotmail dot com
Installed gawk, didn't make any difference.

# sh config.guess
# i686-pc-linux-gnu

Not sure I understand the question regarding what debian it is?... it's a debian install from debian.org?

Will build Apache2 from source and see if that helps.
 [2005-09-15 20:10 UTC] sniper@php.net
I meant what Debian version you have. (they have names like Potato, etc..)
Please send me the config.log from the failing build.
 [2005-09-15 22:52 UTC] dar_tay at hotmail dot com
Debian version is 'sarge'

config log sent via email.
 [2005-09-16 10:15 UTC] sniper@php.net
I don't think this is any bug in PHP, it's just your Debian installation that is really messed up. Can you reproduce this on any other machine??

 [2005-09-16 10:27 UTC] dar_tay at hotmail dot com
I don't see how my install could be messed up, I've only every used apt-get to install packages, this is the first time I've needed to build anything.

Having said that I seem to have solved it this morning, --enable-static seems to have done the trick.

Thanks for taking the time to look into this.
 [2005-09-16 11:25 UTC] sniper@php.net
Let's close this for now. If someone else can actually reproduce this, I'll look again into this.

 
PHP Copyright © 2001-2018 The PHP Group
All rights reserved.
Last updated: Sat Nov 17 02:01:25 2018 UTC