php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #34438 $_FILES problem
Submitted: 2005-09-09 11:34 UTC Modified: 2005-09-09 11:49 UTC
From: schoolgal_hk at yahoo dot com Assigned:
Status: Not a bug Package: Performance problem
PHP Version: 5.0.5 OS: Window 2000
Private report: No CVE-ID: None
 [2005-09-09 11:34 UTC] schoolgal_hk at yahoo dot com
Description:
------------
I use $_FILES['file']['type'] to check the type of a MICROSOFT WORD file while editing it by Microsoft word. 

$_FILES['file']['type'] return the type : application/octet-stream

However, when I finish editing and close the Microsoft Word application. 

$_FILES['file']['type'] can now return the correct type: application/msword

I am now sure whether this is a feature or bug.

Reproduce code:
---------------
$_FILES['file']['type'];

echo "File type :".$_FILES['file']['type'];

Expected result:
----------------
File type :application/msword 


Actual result:
--------------
File type :application/octet-stream


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2005-09-09 11:49 UTC] tony2001@php.net
Sorry, but your problem does not imply a bug in PHP itself.  For a
list of more appropriate places to ask for help using PHP, please
visit http://www.php.net/support.php as this bug system is not the
appropriate forum for asking support questions.  Due to the volume
of reports we can not explain in detail here why your report is not
a bug.  The support channels will be able to provide an explanation
for you.

Thank you for your interest in PHP.


 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Thu Jan 23 06:01:24 2020 UTC