php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #34416 Upload of a big file fails and destroy post data
Submitted: 2005-09-07 23:25 UTC Modified: 2005-09-07 23:44 UTC
From: a dot schilder at gmx dot net Assigned:
Status: Not a bug Package: HTTP related
PHP Version: 5.1.0RC1 OS: Windows XP SP2
Private report: No CVE-ID: None
 [2005-09-07 23:25 UTC] a dot schilder at gmx dot net
Description:
------------
I'm working on a simple file upload form, which works fine for small files. Then I tried to upload files larger than 'upload_max_filesize' (set to 10M) with a file about 21MB to test the error codes in $_FILES['fieldname']['error'].

When submitting the form, the $_POST and $_FILES arrays are empty, although there are other post data in the form (e.g. the session - but I switch to cookies, so I could test it).

It doesn't make a difference which file type I choose or if I add the hidden MAX_FILE_SIZE field or not.

More info:

There is no error in the apache logfiles.
'file_uploads' is 'On'
'post_max_size' is '10M'

Reproduce code:
---------------
A form similar to the one I use:

<form action="photo.php" method="POST" enctype="multipart/form-data" accept-charset="UTF-8">
<input type="file" name="photo_file" />
<input type="hidden" name="some_post_data" />
<input type="submit" />
</form>

Expected result:
----------------
Date in the $_POST array and the $_FILES array, including the correct error code.

Actual result:
--------------
Empty $_POST and $_FILES arrays.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2005-09-07 23:44 UTC] sniper@php.net
Sorry, but your problem does not imply a bug in PHP itself.  For a
list of more appropriate places to ask for help using PHP, please
visit http://www.php.net/support.php as this bug system is not the
appropriate forum for asking support questions.  Due to the volume
of reports we can not explain in detail here why your report is not
a bug.  The support channels will be able to provide an explanation
for you.

Thank you for your interest in PHP.


 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Wed Oct 20 18:03:38 2021 UTC