php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #34398 some PHP extension fail to load...
Submitted: 2005-09-06 22:20 UTC Modified: 2010-12-20 11:57 UTC
Votes:1
Avg. Score:5.0 ± 0.0
Reproduced:1 of 1 (100.0%)
Same Version:1 (100.0%)
Same OS:1 (100.0%)
From: ron dot slayton at e-access dot net Assigned:
Status: Not a bug Package: Dynamic loading
PHP Version: 5.0.4 OS: Windows Server 2003
Private report: No CVE-ID: None
 [2005-09-06 22:20 UTC] ron dot slayton at e-access dot net
Description:
------------
I've installed PHP under C:\PHP, and the extensions under C:\PHP\ext 

IIS version is 6. Had to manually enter a Web Service extension in IIS for PHP. The installer's scriptmap didn't do this for me.

I set IUSR_MACHINENAME permissions on the PHP directory as RX (Read & Execute)

The PHP script will run, but it throws back (dialog box on the webserver):

"PHP Startup: Unable to load dynamic library 'C:\PHP\ext\*.dll' - The specified module could not be found."

The * mean multiple module names. I've turned on all modules to see the extent of the problem. PHP finds and USES most of the modules except:

php_curl.dll
php_exif.dll
php_ifx.dll
php_ldap.dll
php_mcrypt.dll
php_oci8.dll
php_openssl.dll
php_oracle.dll
php_sybase_ct.dll
php_w32api.dll
php_yaz.dll

It pops up this dialog box 3 times per module. 

I didn't have this problem on Windows 2000 Server with IIS 5.

Here is part of php.ini:

; Directory in which the loadable extensions (modules) reside.
extension_dir = C:\PHP\ext\

; Whether or not to enable the dl() function.  The dl() function does NOT work
; properly in multithreaded servers, such as IIS or Zeus, and is automatically
; disabled on them.
enable_dl = Off

extension=php_bz2.dll
extension=php_cpdf.dll
extension=php_curl.dll
extension=php_dba.dll
extension=php_dbase.dll
extension=php_dbx.dll
extension=php_exif.dll
extension=php_fdf.dll
extension=php_filepro.dll
extension=php_gd2.dll
extension=php_gettext.dll
extension=php_ifx.dll
extension=php_iisfunc.dll
extension=php_imap.dll
extension=php_interbase.dll
extension=php_java.dll
extension=php_ldap.dll
extension=php_mbstring.dll
extension=php_mcrypt.dll
extension=php_mhash.dll
extension=php_mime_magic.dll
extension=php_ming.dll
extension=php_mssql.dll
extension=php_msql.dll
extension=php_mysql.dll
extension=php_oci8.dll
extension=php_openssl.dll
extension=php_oracle.dll
extension=php_pdf.dll
extension=php_pgsql.dll
extension=php_shmop.dll
extension=php_snmp.dll
extension=php_sockets.dll
extension=php_sybase_ct.dll
extension=php_tidy.dll
extension=php_w32api.dll
extension=php_xmlrpc.dll
extension=php_xsl.dll
extension=php_yaz.dll
extension=php_zip.dll

Please help me fix this problem, this is a server that needs to go into production soon.

        Ron

Reproduce code:
---------------
<HTML>
<BODY>

<?php phpinfo(); ?> 

</BODY>
</HTML>

Expected result:
----------------
The test script coming out with all modules loaded and no error dialog boxes on the server.

Actual result:
--------------
Errors loading certain PHP modules.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2005-09-07 09:27 UTC] sniper@php.net
Sorry, but your problem does not imply a bug in PHP itself.  For a
list of more appropriate places to ask for help using PHP, please
visit http://www.php.net/support.php as this bug system is not the
appropriate forum for asking support questions.  Due to the volume
of reports we can not explain in detail here why your report is not
a bug.  The support channels will be able to provide an explanation
for you.

Thank you for your interest in PHP.


 [2010-12-20 11:57 UTC] jani@php.net
-Package: Tidy +Package: Dynamic loading
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Sat Jul 24 14:01:23 2021 UTC