php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #34359 http_fopen_wrapper cleanup
Submitted: 2005-09-03 13:46 UTC Modified: 2005-12-08 03:54 UTC
From: nlopess@php.net Assigned: pollita
Status: Closed Package: HTTP related
PHP Version: 6CVS-2005-09-03 (CVS) OS: *
Private report: No CVE-ID:
 [2005-09-03 13:46 UTC] nlopess@php.net
Description:
------------
I've cleaned up the http fopen wrapper, because I got a 2 valgrind errors on it.

Apart of fixing the bug, I've also removed an unecessary assignement to http_header_line, because php_stream_gets() already truncates the string, so there's no need to do it twice (I've tested it by sending a large (>1024) string in the headers).

Patch: http://mega.ist.utl.pt/~ncpl/php_streams_mem.txt

Reproduce code:
---------------
php -r "file_get_contents('http://www.xpto.com');"


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2005-09-19 16:54 UTC] tony2001@php.net
Sara, could you plz take care of it?
 [2005-12-08 03:54 UTC] iliaa@php.net
This bug has been fixed in CVS.

Snapshots of the sources are packaged every three hours; this change
will be in the next snapshot. You can grab the snapshot at
http://snaps.php.net/.
 
Thank you for the report, and for helping us make PHP better.


 
PHP Copyright © 2001-2014 The PHP Group
All rights reserved.
Last updated: Sat Apr 19 17:01:54 2014 UTC