php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #34285 IIS will not load php.ini
Submitted: 2005-08-28 07:53 UTC Modified: 2005-08-28 16:28 UTC
From: darrenkent at comcast dot net Assigned:
Status: Not a bug Package: *Configuration Issues
PHP Version: 5.0.4 OS: Windows XP SP2
Private report: No CVE-ID: None
 [2005-08-28 07:53 UTC] darrenkent at comcast dot net
Description:
------------
I have verified everything is configured properly (i.e path to php directory is set in Windows PATH variable, folder permissions are correct, IIS is configured properly to use the correct file - php5isapi.dll, php.ini is configured properly), but when I run phpinfo() it says the php.ini file is located in C:\WINDOWS. It then loads default values and will not load the libmysql.dll or php_mysqli.dll files. I even tried moving the php.ini file into the C:\WINDOWS directory and it still loads a default version of php.ini that isn't configured for anything. I have installed many versions of PHP (since version 3) on many different versions of IIS and have never encountered this problem in the past. Any ideas??


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2005-08-28 16:28 UTC] sniper@php.net
Sorry, but your problem does not imply a bug in PHP itself.  For a
list of more appropriate places to ask for help using PHP, please
visit http://www.php.net/support.php as this bug system is not the
appropriate forum for asking support questions.  Due to the volume
of reports we can not explain in detail here why your report is not
a bug.  The support channels will be able to provide an explanation
for you.

Thank you for your interest in PHP.


 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Sat Sep 24 22:05:52 2022 UTC