php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #34248 PDO connects to database but do not execute sql statements
Submitted: 2005-08-25 14:39 UTC Modified: 2005-08-31 10:47 UTC
From: joel at everlast dot se Assigned: wez (profile)
Status: Not a bug Package: PDO related
PHP Version: 5.1.0RC1 OS: Debian GNU/Linux 2.4.24-1-386
Private report: No CVE-ID: None
 [2005-08-25 14:39 UTC] joel at everlast dot se
Description:
------------
I were using 5.1.0Ob2 and pdo wich worked almost fine, everything but transaction worked. So I updated to 5.1.0RC1 and suddenly all pdo related code cease to work.

I'm using apache1.3 as the httpd.

Se link for more information and code example.

Reproduce code:
---------------
http://bowser.everlast.se/~qzio/pdofailure.php

Expected result:
----------------
I want it to execute the $pdo->query() and print out the results.


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2005-08-25 14:44 UTC] joel at everlast dot se
Sorry for my bad english, is there a way to edit the original description and correct my spellings?
 [2005-08-30 00:31 UTC] iliaa@php.net
What is the version of your MySQL server and what is the version of the mysql client library PHP is linked against?
 [2005-08-31 10:21 UTC] joel at everlast dot se
I think it was the debian version 4.1.11a-4sarge1 of libmysqlclient14. And 4.1.11a-4sarge1 of mysql-server-1.4.

as you can read in the url:

"
 * ( qzio@liquid:evs )$ mysql --version
 * mysql  Ver 12.22 Distrib 4.0.24, for pc-linux-gnu (i386)
"

I were using debian sarge. The strange thing was that it worked fine with mysql_connect() in php5.1RC1 and that pdo worked just fine with php5.1Ob1 but not with php5.1RC1.

Anyways, since i'm on a scedule and really needed to get some things done, I did a clean re-install with lighttpd and snaps.php.net version of php5.1RC installed mysql5.1 of the debian sarge packages and now everything works as i want it to.

I dont know if this bug was becouse of my f*cked-up installation or something else, but since i've reinstalled my system and everything works for me now (hey, pdo is really neat!) I don't mind closing this bugreport.

This is my first report so i'm not sure how things work, should I close it or is that something the developers do?
 [2005-08-31 10:47 UTC] sniper@php.net
We bogus. You code. :)

 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Tue Dec 01 18:01:23 2020 UTC