php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #34189 After Configure and Make can load symbol ap_loaded_modules
Submitted: 2005-08-18 19:40 UTC Modified: 2005-08-22 23:19 UTC
Votes:2
Avg. Score:3.0 ± 2.0
Reproduced:1 of 1 (100.0%)
Same Version:1 (100.0%)
Same OS:1 (100.0%)
From: david dot marek at mattel dot com Assigned:
Status: Wont fix Package: Apache related
PHP Version: 5.1.0b3 OS: AIX 5.0
Private report: No CVE-ID: None
Have you experienced this issue?
Rate the importance of this bug to you:

 [2005-08-18 19:40 UTC] david dot marek at mattel dot com
Description:
------------
We configure and make PHP and then load it into apache.  This then brings up the error below on the server. 

This works on the same build for Solaris but this is AIX.  

Reproduce code:
---------------
Error occurs when either really simple or has everything in it.  

Expected result:
----------------
Module loads and PHP pages viewable

Actual result:
--------------
Configuration changes cannot be saved until the following validation errors are corrected:
Unknown - Configuration changes prevented server startup. "Cannot load /opt/oracle/product/DCOM/AS10g/Apache/Apache/libexec/libphp5.so into server: rtld: 0712-001 Symbol ap_loaded_modules was referenced from module /opt/oracle/product/DCOM/AS10g/Apache/Apache/libexec/libphp5.so(), but a runtime definition of the symbol was not found.". Check line 195 in file /opt/oracle/product/DCOM/AS10g/Apache/Apache/conf/httpd.conf. Resolution: Please make sure that the value above is correct.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2005-08-18 22:14 UTC] david dot marek at mattel dot com
I am doing this right now.  I do have 1 question.  When I search for ap_loaded_modules on Solaris it is not part of my libphp5.so file but it is on AIX.
 [2005-08-18 22:47 UTC] iliaa@php.net
what httpd headers do you have available on you system?
 [2005-08-18 22:49 UTC] sniper@php.net
And you're sure your installation on AIX has everything it needs? What compiler do you use there? 

 [2005-08-18 22:53 UTC] david dot marek at mattel dot com
Not sure if we have everything but I was told we did. I am picking this up as I did the solaris install before.  Is there some list I can check from other than the manual as I looked at that.  I also believe we are using xlc as the compiler.  

Not sure on the headers question.  How do I tell.  This was an install from Oracle iAS but this same version didn't cause me issues on Solaris.
 [2005-08-18 22:57 UTC] iliaa@php.net
Check for the contents of the include/ directory in Apache dirs
 [2005-08-18 22:59 UTC] david dot marek at mattel dot com
Looks like the headers are there from looking and comparing to other systems.
 [2005-08-18 23:07 UTC] sniper@php.net
Try with stock apache 1.3.33 installation, not with some Oracle crap..also, use GCC as compiler.


 [2005-08-18 23:28 UTC] david dot marek at mattel dot com
Starting to do the apache standalone as a test but we need to use iAS plus we have it working on solaris. Is there some special AIX stuff we need to do in the configure.  Any env variables that would differ.  I haven't been able to find anything.
 [2005-08-18 23:46 UTC] sniper@php.net
Let's see first if this works any better with real Apache.
Don't reply before you get results.

 [2005-08-19 06:52 UTC] david dot marek at mattel dot com
It works with the build of Apache 1.3.33 but it still does not work with Oracle's Apache.  We are using GCC and the dependencies have all be recompiled.  When I build PHP on Solaris I don't get the symbol referenced in the libphp5.so but on AIX I do.  Is there a reason the make is added the symbol to the AIX build and not the Solaris build. Everything else is the same.  I grep on ap_loaded_modules on libphp5.so and I get a value back on AIX and that appears to be the culprit.
 [2005-08-19 11:46 UTC] sniper@php.net
If it works with Apache 1.3.33, it's no bug in PHP. Complain to Oracle. Also, we have never said we support anything but the 'real' apache..

 [2005-08-22 16:35 UTC] david dot marek at mattel dot com
I do have question.  If we build this agains solaris all is good.  Meaning we don't see the ap_Loaded_modules in the php library.  In AIX we do.  This is the compile and build on the PHP side.  Is this something we can remove or find a way not to include.  We can't move forward with the migration without it so any help would be great.

Thanks!
 [2005-08-22 19:18 UTC] david dot marek at mattel dot com
I am reopening as I have some questions you may be able to help with. I hope!
 [2005-08-22 22:30 UTC] sniper@php.net
Friendly advise: Don't use AIX. 
I changed this to "wont fix". Ask IBM or Oracle to fix their crappy software.

 [2005-08-22 23:19 UTC] david dot marek at mattel dot com
Understood.  IBM and Oracle do have issues.  

I did modify php_apache.c in sapi/apache to remove the get_modules and it now works (No the best answer)  Something on AIX doesn't like get_modules and includes it in the library. Solaris doesn't do this.

Thanks!
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Tue Jul 16 18:01:26 2019 UTC