php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #34177 unable to send e-mail
Submitted: 2005-08-17 21:41 UTC Modified: 2005-08-17 21:43 UTC
From: wael at areaband dot com Assigned:
Status: Not a bug Package: *Configuration Issues
PHP Version: 4.4.0 OS: windows 2003
Private report: No CVE-ID: None
 [2005-08-17 21:41 UTC] wael at areaband dot com
Description:
------------
after insallting drupal, i was able to browse Index.php without a problem. after creating the first account, php was suppossed to send e-mai but it couldn't.i supplied the php.ini , which is located in c:\windwos , with the right options :

[mail function]
;For Win32 only.
SMTP = exchange04
smtp_port = 25

;For Win32 only.
sendmail_from = wael@areaband.com

the exchange04 server is running on a local network so it's not a resolving issue. 
after updating the .ini file, the drupal page still shows the following error :

warning: mail(): Failed to connect to mailserver at "localhost" port 25, verify your "SMTP" and"smtp_port"setting in php.ini or use ini_set() in c:\inetpub\wwwroot\modules\user.module on line 366.

it's seems that PHP, for some reason, is not able to take the configuration right. 

please help me with this and thanks for your time.

Wael Altaqi
wael@areaband.com


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2005-08-17 21:43 UTC] tony2001@php.net
Sorry, but your problem does not imply a bug in PHP itself.  For a
list of more appropriate places to ask for help using PHP, please
visit http://www.php.net/support.php as this bug system is not the
appropriate forum for asking support questions.  Due to the volume
of reports we can not explain in detail here why your report is not
a bug.  The support channels will be able to provide an explanation
for you.

Thank you for your interest in PHP.


 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Sat Sep 24 23:05:52 2022 UTC