php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #34165 snmpapp.conf open errors
Submitted: 2005-08-17 07:31 UTC Modified: 2005-08-18 02:27 UTC
From: kevin at kobrien dot net Assigned:
Status: Not a bug Package: SNMP related
PHP Version: 5CVS-2005-08-17 (snap) OS: Linux (Red Hat 4ES)
Private report: No CVE-ID: None
 [2005-08-17 07:31 UTC] kevin at kobrien dot net
Description:
------------
I know this is a duplicate of #32613, but I am unable to submit a comment to a closed ticket.


Reproduce code:
---------------
I build php5-STABLE-200508170435 with:

./configure --with-snmp


Expected result:
----------------
If I run sapi/cli/php --version for php 4.4.0 built with the same arguments, I get:

[not-root@host php-4.4.0]$ sapi/cli/php --version
PHP 4.4.0 (cli) (built: Aug 11 2005 23:47:50)
Copyright (c) 1997-2004 The PHP Group
Zend Engine v1.3.0, Copyright (c) 1998-2004 Zend Technologies

Actual result:
--------------
[not-root@host php5-STABLE-200508170435]$ sapi/cli/php --version
PHP 5.0.5-dev (cli) (built: Aug 16 2005 22:25:22)
Copyright (c) 1997-2004 The PHP Group
Zend Engine v2.0.4-dev, Copyright (c) 1998-2004 Zend Technologies
No log handling enabled - turning on stderr logging
read_config_store open failure on /var/net-snmp/snmpapp.conf
read_config_store open failure on /var/net-snmp/snmpapp.conf
read_config_store open failure on /var/net-snmp/snmpapp.conf

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2005-08-17 17:09 UTC] kevin at kobrien dot net
I doesn't appear to be fixed in CVS since I used the CVS snapshot and the problem still exists.
 [2005-08-17 17:41 UTC] sniper@php.net
Please try using this CVS snapshot:

  http://snaps.php.net/php5-latest.tar.gz
 
For Windows:
 
  http://snaps.php.net/win32/php5-win32-latest.zip


 [2005-08-17 18:32 UTC] kevin at kobrien dot net
Same result:

[non-root@host php5-200508171430]$ sapi/cli/php --version
PHP 5.1.0-dev (cli) (built: Aug 17 2005 09:27:08)
Copyright (c) 1997-2005 The PHP Group
Zend Engine v2.1.0-dev, Copyright (c) 1998-2005 Zend Technologies
No log handling enabled - turning on stderr logging
read_config_store open failure on /var/net-snmp/snmpapp.conf
read_config_store open failure on /var/net-snmp/snmpapp.conf
read_config_store open failure on /var/net-snmp/snmpapp.conf

I had to add --without-pear to configure because the xmlrpc would fail to compile correctly.  It compiled fine last night with snapshot php5-STABLE-200508170435.  I can open another bug ticket if you would like or just chalk it up to someone in mid-development on the 5.1 branch.
 [2005-08-17 19:07 UTC] sniper@php.net
What compile errors? Also, what libxml2 version you have installed? What net-snmp version?

 [2005-08-18 02:08 UTC] sniper@php.net
Your versions:
net-snmp: 5.1.2-11 (RH 4ES RPM)
libxml2: 2.6.16-6 (RH 4ES RPM)

(report the xmlrpc bug separately, and with ONLY the errors, not the whole dump from make..)

 [2005-08-18 02:20 UTC] sniper@php.net
This error happens since you have too old net-snmp libraries installed which don't have NETSNMP_DS_LIB_DONT_PERSIST_STATE.
Reverting the change would re-introduce the huge memleaks so that is not an option. The fix is just to upgrade net-snmp to 5.2.x.

 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Mon Aug 10 20:01:24 2020 UTC