php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #34136 php.ini path humbug
Submitted: 2005-08-15 15:10 UTC Modified: 2005-08-15 18:05 UTC
From: x2uk at compuserve dot de Assigned:
Status: Not a bug Package: *Configuration Issues
PHP Version: 5.1.0b3 OS: w2k
Private report: No CVE-ID: None
 [2005-08-15 15:10 UTC] x2uk at compuserve dot de
Description:
------------
What php.ini says :
; PHP looks for it
; - in the current working directory,
; - in the path designated by the environment variable PHPRC, and
; - in the path that was defined in compile time (in that order).
That's humbug !
It was true for PHP502, though, but not PHP 5.1.0b3.

I had to put that sodden file into the Windows dir.
After that it was read the extension_dir set properly.
Why the hell has php.ini to reside there again ?
You had it right for PHP502 !!!

Besides, one can install PHP w/i minutes !!! - 
provided you work & documentation wouldn't be so sluggishly wrong.


Reproduce code:
---------------
Installation PHP510b3

Expected result:
----------------
PHP510b3 ought to find php.ini in the directory where it resides itself - according to the documention w/i php.ini itself and according to php_manual_en.chm.

Actual result:
--------------
PHP510b3 won't find php.ini, as documented, 
and therfore the extension_dir will be wrongly set.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2005-08-15 16:43 UTC] sniper@php.net
Sorry, but your problem does not imply a bug in PHP itself.  For a
list of more appropriate places to ask for help using PHP, please
visit http://www.php.net/support.php as this bug system is not the
appropriate forum for asking support questions.  Due to the volume
of reports we can not explain in detail here why your report is not
a bug.  The support channels will be able to provide an explanation
for you.

Thank you for your interest in PHP.


 [2005-08-15 18:05 UTC] x2uk at compuserve dot de
Your answer is rubbish !
You claim / What php.ini says :
; PHP looks for it
; - in the current working directory,
; - in the path designated by the environment variable PHPRC, and
; - in the path that was defined in compile time (in that order).
That's humbug !
It was true for PHP502, though, but not PHP 5.1.0b3.
"

Therefore it's a bug & cost me a lot of time to work it out!

I definitely disagree with you.

If a car dealer claims "This car accelerates 
from 10mph to 80mph in 2.5 sec flat", 
and it doesn't ... 
well, that's what I term a bug.

So,please, no cheeky answers.
@
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Sat Sep 24 23:05:52 2022 UTC