|  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #34047 When compile php cannot generate
Submitted: 2005-08-09 09:47 UTC Modified: 2005-08-17 01:00 UTC
Avg. Score:4.5 ± 0.8
Reproduced:29 of 29 (100.0%)
Same Version:8 (27.6%)
Same OS:6 (20.7%)
From: calvinscy at hotmail dot com Assigned:
Status: No Feedback Package: Compile Failure
PHP Version: 5.0.4 OS: Solaris 8
Private report: No CVE-ID: None
Have you experienced this issue?
Rate the importance of this bug to you:

 [2005-08-09 09:47 UTC] calvinscy at hotmail dot com
When compiling the php5.0.4 download from your site, it cannot generate a file called

But if I download php-5.0.4.tar.gz from it can. After "make install" completed I can see the created under apache2/modules directory.

I try the php4 from your site as well, it cannot generate too!


Add a Patch

Pull Requests

Add a Pull Request


AllCommentsChangesGit/SVN commitsRelated reports
 [2005-08-09 10:21 UTC]
Please try using this CVS snapshot:
For Windows:

 [2005-08-17 01:00 UTC] php-bugs at lists dot php dot net
No feedback was provided for this bug for over a week, so it is
being suspended automatically. If you are able to provide the
information that was originally requested, please do so and change
the status of the bug back to "Open".
 [2005-08-28 21:12 UTC] rob at silverarcher dot com
The problem still seems to be occurring.  php-5.0.4 and php-
latest both will not compile the

I'm hoping can help...
 [2005-08-28 21:26 UTC] rob at silverarcher dot com
sunfreeware doesn't work either.  I'm using Fedora Core 4 and 
cannot get this one part to compile.
 [2005-12-19 19:07 UTC] till at klimpong dot com
I'm having the same issue (it didn't build with the 5.1.1 when I downloaded it from the website.

My OS: FreeBSD 4.11-stable
My libtool is: 1.5.x

Using the latest snapshot solves this problem, but I am wondering why.

Happy to provide more feedback when asked. :-)
 [2005-12-31 05:38 UTC] ian at manageads dot com

Same stinking message!

httpd failed. The error was: Starting httpd: Syntax error on line 33 of /etc/httpd/conf/httpd.conf:
API module structure `php5_module' in file /usr/local/apache2/modules/ is garbled - perhaps this is not an Apache module DSO?
 [2006-05-10 06:44 UTC] info at urs-martini dot de
I have apache2.2.2 on my debian box and tried to install php5 (5.1.2 and 5.1.4 don't work!). Compiling is without problems but apache does not start anymore:

httpd: Syntax error on line 128 of /usr/local/apache2/conf/httpd.conf: Syntax error on line 1 of /etc/apache2/mods-enabled/php5.load: API module structure `php5_module' in file /usr/local/apache2/modules/ is garbled - perhaps this is not an Apache module DSO?

I did not find anything helpful on the net...
 [2006-05-25 10:13 UTC] smirko at poczta dot onet dot pl
Just compiled PHP-5.1.4. Same issue - Apache not starting with message " is garbled".
Hope it's resolved soon...
 [2006-05-25 11:18 UTC] smirko at poczta dot onet dot pl
I'm pleased to say - it was rather an Apache issue than that of PHP. I've just installed Apache 2.2.2 and voila. Works like a charm! No garbled libphp...
 [2006-07-21 12:50 UTC] neo at clover dot co dot za
I've got a similar problem with Apache 2.2.2 and PHP 5.1.4. Compiling of Apache and PHP goes through smooth. On their own Apache and PHP work perfect (without the declared in httpd.conf). Once I try to load PHP module in Apache I get ' is garbled' message, although Apache still starts.

This is running on SLED 10. Apache 2.0.58 with PHP 5.1.4 worked fine on SUSE 9.3. So busy downloading Apache 2.0.58 ...
 [2006-07-21 18:01 UTC] neo at clover dot co dot za
OK. With Apache 2.0.58 it compiled both Apache and PHP without any errors, as before. But this time the seems to be loaded just fine.

"Apache/2.0.58 (Unix) PHP/5.1.4 Server at localhost Port 80"

The issue that I have now is that the .php pages are not parsed, the source is just displayed in plane text ...? The other funny thing that I picked up, the requests to any of the pages hosted by Apache are not reflected in the access_log ...?
 [2006-07-21 19:15 UTC] neo at clover dot co dot za
OK. I think this is the last one from me.
Apache 2.0.58 and PHP 5.1.4 combination seems to work just fine on SLED 10. It is exactly the same versions that worked on SUSE 9.3 before I upgraded to SLED. Although I still need to get the rest of my extensions running with this PHP install, I'm sure it is not going to be a problem.
It's a pity though that I can't use Apache 2.2.2, well ...
PHP Copyright © 2001-2023 The PHP Group
All rights reserved.
Last updated: Fri Dec 01 11:01:27 2023 UTC