php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #34010 bundled sqlite version:2, pdo-sqlite:3
Submitted: 2005-08-05 17:28 UTC Modified: 2005-08-05 19:32 UTC
From: akorthaus at web dot de Assigned:
Status: Wont fix Package: SQLite related
PHP Version: 5.1.0b3 OS: Linux 2.4.31 (gentoo)
Private report: No CVE-ID: None
Have you experienced this issue?
Rate the importance of this bug to you:

 [2005-08-05 17:28 UTC] akorthaus at web dot de
Description:
------------
If I install php with sqlite (and sqlite-utf8), I geht the following version:

SQLite
SQLite support	enabled
PECL Module version 	2.0-dev $Id: sqlite.c,v 1.165 2005/06/17 16:42:53 sniper Exp $
SQLite Library 	2.8.14
SQLite Encoding 	UTF-8

If I install pdo-sqlite, I get the following version:

pdo_sqlite
PDO Driver for SQLite 3.x	enabled
PECL Module version 	(bundled) 0.9 $Id: pdo_sqlite.c,v 1.10 2005/07/27 04:07:11 wez Exp $
SQLite Library 	3.2.2

Would be great of the two versions could be more in sync, to make it possible to use both php-extensions with the same data-files.


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2005-08-05 19:32 UTC] tony2001@php.net
I doubt that will change ever.
If you want to use Sqlite 3 with ext/sqlite - use external SQLite library and configure PHP with --with-sqlite=<DIR> option.
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Fri Aug 07 04:01:25 2020 UTC