php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #33936 fsockopen invalid argument (22)
Submitted: 2005-07-31 20:25 UTC Modified: 2005-08-01 00:44 UTC
From: dev at mentortechies dot net Assigned:
Status: Not a bug Package: *Network Functions
PHP Version: 4.4.0 OS: Linux
Private report: No CVE-ID: None
 [2005-07-31 20:25 UTC] dev at mentortechies dot net
Description:
------------
Hello,

We are getting the error as 

Warning: fsockopen(): php_network_getaddresses: getaddrinfo failed: hostname nor servname provided, or not known in /usr/home/project/www/tes1.php on line 2

Warning: fsockopen(): unable to connect to <SITENAME > Invalid argument (22)

we are on one of the best servers in the world and not able to find the solution as tried on different servers also.

We are sending data from one site to another via fsockopen command and linking both of then for equivalent data.

Let us know what can solve the problem.



Expected result:
----------------
When we run the code above we only want the script which we are calling by fsockopen should run successfully as a normal script and all the arguments shld be send to the other site so it can be utilised by the called script.


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2005-08-01 00:44 UTC] sniper@php.net
Sorry, but your problem does not imply a bug in PHP itself.  For a
list of more appropriate places to ask for help using PHP, please
visit http://www.php.net/support.php as this bug system is not the
appropriate forum for asking support questions.  Due to the volume
of reports we can not explain in detail here why your report is not
a bug.  The support channels will be able to provide an explanation
for you.

Thank you for your interest in PHP.


 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Thu Oct 17 20:01:28 2019 UTC