php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #33906 value comparsion doesn't work as expected
Submitted: 2005-07-28 16:07 UTC Modified: 2005-07-28 16:32 UTC
From: ray-chords at gmx dot net Assigned:
Status: Not a bug Package: SimpleXML related
PHP Version: 5.0.4 OS: Debian Sarge
Private report: No CVE-ID: None
 [2005-07-28 16:07 UTC] ray-chords at gmx dot net
Description:
------------
Intention was to compare a string value with an xml node value. But direct access to the value fails.

Reproduce code:
---------------
<?php
$xml_string = <<<EOD
<?xml version="1.0" encoding="iso-8859-1" standalone="yes" ?>
<document>
    <command default="yes"><id><![CDATA[li]]></id></command>
    <command><id><![CDATA[reg]]></id></command>
    <command><id><![CDATA[cq]]></id></command>
    <command><id><![CDATA[tipp]]></id></command>
    <command><id><![CDATA[pwd]]></id></command>
</document>
EOD;

$xml = simplexml_load_string($xml_string);
$template = $xml->xpath('/document/command/id');
foreach ($template as $v) {
    $out = ($v->id == 'pwd') ? 'OK' : 'FALSE'; 
    print $out . "\n";
}
?>

Expected result:
----------------
I'd expected an 'OK' in the last loop. But I always get 'FALSE'.


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2005-07-28 16:23 UTC] sniper@php.net
RTFM. You have to cast to string first.

 [2005-07-28 16:32 UTC] ray-chords at gmx dot net
no, casting to string has no effect.

As I find out, a SimpleXMLElement including just one node with only one value must be called directly.

change line 17: $out = ($v->id == 'pwd') ? 'OK' : 'FALSE'; 
to:             $out = ($v == 'pwd') ? 'OK' : 'FALSE';

and it works as expected.
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Sun Oct 02 09:05:52 2022 UTC