php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #33882 php.ini search path with CLI api
Submitted: 2005-07-27 14:52 UTC Modified: 2005-07-27 17:10 UTC
From: hartmut@php.net Assigned:
Status: Closed Package: *Configuration Issues
PHP Version: 5CVS-2005-07-27 (dev) OS: linux
Private report: No CVE-ID:
 [2005-07-27 14:52 UTC] hartmut@php.net
Description:
------------
the first place to look for a php.ini is supposed to be 
the directory where the php binary is installed

this is done by taking the dirname out of 
sapi_module.executable_location
and then appending php.ini

on the other hand sapi_module.executable_location
is just a copy of argv[0] for CLI

so if the CLI is just called as 'php' it looks for php.ini
in "php/php.ini"

a realpath() call should be added somewhere to fix this

Reproduce code:
---------------
strace php 2>&1 | grep php.ini

Expected result:
----------------
php.ini looked for in /usr/local/bin/php.ini

Actual result:
--------------
php.ini looked for in php/php.ini

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2005-07-27 17:10 UTC] hholzgra@php.net
This bug has been fixed in CVS.

Snapshots of the sources are packaged every three hours; this change
will be in the next snapshot. You can grab the snapshot at
http://snaps.php.net/.
 
Thank you for the report, and for helping us make PHP better.


 
PHP Copyright © 2001-2014 The PHP Group
All rights reserved.
Last updated: Sat Apr 19 19:02:15 2014 UTC