php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #3377 Calls to imap_check() causes php to GP.
Submitted: 2000-02-01 14:11 UTC Modified: 2005-03-31 16:13 UTC
From: mike at bedarra dot com Assigned:
Status: Wont fix Package: Reproducible Crash
PHP Version: 3.0.14 OS: Windows 95 (.950 C)
Private report: No CVE-ID: None
Have you experienced this issue?
Rate the importance of this bug to you:

 [2000-02-01 14:11 UTC] mike at bedarra dot com
 The following cause a GP. Opening an closing without the call to _check seems to be ok. 
I am connecting to a CommuniGatePro server.  

<?
        $mbox = imap_open("{someserver.com}public",
                          "info", "test");
        $check = imap_check($mbox);
        //print("Msg Count: ", $check->Nmsgs);
        imap_close($mbox);
?>


Registers:

PHP caused an invalid page fault in
module <unknown> at 0000:0029656d.
Registers:
EAX=00000000 CS=0137 EIP=0029656d EFLGS=00010206
EBX=006bed8c SS=013f ESP=006becdc EBP=006bfda4
ECX=00000001 DS=013f ESI=00000000 FS=1917
EDX=00000005 ES=013f EDI=006bed4c GS=0000
Bytes at CS:EIP:

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2000-02-03 14:23 UTC] mike at bedarra dot com
Same problem under Win NT 4, php crashes.
 [2005-03-31 16:13 UTC] php-bugs at lists dot php dot net
We are sorry, but we do not support PHP 3 related problems anymore.
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Tue Jul 23 04:01:26 2019 UTC