php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Doc Bug #33722 Czech CHM Manual Errors
Submitted: 2005-07-16 13:14 UTC Modified: 2005-08-03 11:18 UTC
Votes:2
Avg. Score:2.5 ± 1.5
Reproduced:2 of 2 (100.0%)
Same Version:1 (50.0%)
Same OS:1 (50.0%)
From: oburgr at volny dot cz Assigned: derick (profile)
Status: Closed Package: Documentation problem
PHP Version: Irrelevant OS: WinXP SP2
Private report: No CVE-ID: None
 [2005-07-16 13:14 UTC] oburgr at volny dot cz
Description:
------------
I?ve downloaded czech documentation file in CHM format for windows (php_manual_cs.chm). If i open this file and after that i want to open any section, i get an error message. For example... I try to open last section "Copyright" and this error message appears: "h:/phpdocs/cs/copyright.html not found. Please check if the path or internet adress are correct (this is the eghlish transalation from the czech language). In english file (php_manual_en.chm) is everything ok...


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2005-07-16 13:58 UTC] dmytton@php.net
Confirmed
 [2005-07-18 09:18 UTC] vrana@php.net
NL is the same (bug #33735).
 [2005-07-18 09:28 UTC] derick@php.net
yeah, for some reason it doesn't translate the paths anymore. Of course, when I tested the builds on my computer it would work, because I've this H: drive :-)
 [2005-07-18 14:49 UTC] nlopess@php.net
How are you making the chms? I've built the czech manual and I have no such problems (I've deleted the html folders before testing).

The correct build script would be:
./configure --with-lang=$lang
make && make chm

If you are using the html files from another machine, you just need to untar the files to the phpdoc-all/html folder.

Also, maybe you have changed the make_chm.bat script to reflect the path to your chm compiler, but don't forget to update it to the lastest cvs version.

Well, this is all obvious, but sometimes we miss something :)
 [2005-07-18 14:53 UTC] derick@php.net
Using Linux to build the manuals, and windows for the CHMs. But the ones I built now work, except that my windows refuses to show them after updating with the latest security patches :I
 [2005-07-18 16:18 UTC] nlopess@php.net
lol
If PHP had a certificate we could sign the chm files. I think that would solve such problems.
 [2005-08-03 11:18 UTC] derick@php.net
This bug has been fixed in the documentation's XML sources. Since the
online and downloadable versions of the documentation need some time
to get updated, we would like to ask you to be a bit patient.

Thank you for the report, and for helping us make our documentation better.


 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Mon Jan 25 13:01:23 2021 UTC